Unfortunately app stopped ! 4.4


(Developer Tech) #1

Describe your issue

App crashed after opening

Steps to reproduce the issue

Expected Behaviour

Opened

Actual Behaviour

App crashes after opening

Android version

4.4


Apk cannot be opened after update
App stop works on some phones
#2

Nice error message which you showed us.
Now let’s find a wizard to fix this exact problem.


#3

(Nikhil27B YT) #4

Show screen shot and blocks


(Seun Tunde) #5

Hello there…
Ok so last week I had completed and built my app with the previous version of Kodular and all worked fine. I started a new project in the new Kodular Draco version and the app just shows the splash image and crashes when I run it on my Android 4.4 device.

The app is very simple so I don’t understand why this is happening. Any help will be appreciated. I’ve included screenshots and blocks and aia file. Thanks.

WordGameCheat1.aia (625.8 KB)


(Seun Tunde) #6

Sorry that last block was incorrect. The updated one is included below. I also added the error screenshot. Thanks in advance and sorry for any inconvenience.


(Developer Tech) #7

This is showing on mine also
Always dont post how to askuse question
@Peter :joy::joy:
@Mika why this error on kitkat


#8

If you give bad info i have to post the link. I always hope users will learn from that but some users never learn.


(Developer Tech) #9

why that error !
See above


(Philipp Lang) #10

You didnt change the screen right.


(Seun Tunde) #11

I’m sorry, I don’t understand what you mean


(Philipp Lang) #12

If you change your screen, you have to close the screen which is open atm.


(Seun Tunde) #13

Oh that…I’ve never had to do that before though for the splash screen cos I usually use the splash image option in screen 1 menu. But the issue is even if I remove the splash screen, it app itself won’t open up at all and shows that error message :disappointed:. All these issues on 4.4 Kitkat started with the Kodular Draco update. Even some projects I had created previously which worked flawlessly before the update don’t work after I rebuilt their apk and installed on my 4.4 Kitkat device :expressionless:…anyone else having this issue?


(Nathan) #14

Maybe it’s because you’re setting a URL as a start value, why not just goto it directly after pressing the button? What is the point, you’re going to the same screen.


(Seun Tunde) #15

Thanks Nathan.
I already tried that, it didn’t work. Also it wouldn’t explain why my previous app which worked well before the Kodular Draco update crashes now :weary:


(Nathan) #16

Does your app crash on run or when Button 4 is pressed?


(Mudit Agrawal) #17

I am getting the exact same problem. The app is not at all starting in 4.4 version devices. I have a device with 4.4.2 and another with 4.4.4 version. Exiting with unfortunately, the app has stopped message.


(Developer Tech) #18

Yes when app is opened instantly crashes !


(opensertk) #19

Same error here,

unfortunately, xxx has stopped.

The error happens even the project has just one button but nothing else.
The device with error shown is on android 4.4.2
However, the error doesn’t happen on either android 5.1.1 or android 7.1.2.

Hope there will be a solution asap.:thinking:


#20

Guy’s?
If a app crashes then please provide a logcat for us:

How?