Uploading a Video in Kodular (no cloud option)

Kodular apk limit is 32mb however, see below

Thanks a lot for replying. I will study that and explore. If i could keep the file size to less than 30 mb, is there a way out ? I tried uploading the video (11 MB), but when i exported into apk, got error 701… and still could not find a solution for that error.

You have to go this way to upload a big file (video, …) to the assets:

Thanks, i used your other method mentioned earlier and uploaded a 20 MB video file (its .3gp), but when i open the apk, and try playing that video, still getting the Error 701… any way out pls.
The one which i uploaded in kodular asset was 1.5 mb (.3gp file) which i replaced in the folder using APK Editor studio.

Team, kindly request an update please. i am stuck here and could not move forward

Please, learn to be patient.


If you don’t get along with the procedure from “How to build a big app”, why don’t you make it easy for yourself and follow my suggestion:

This will definitely work if your APK is ≤ 32 MB and the aia < 24.5MB.
See also here:

Thanks a lot for replying.
I have tried the options suggested in your discussions.

Steps followed

  1. Edited the video file ‘sample.3gp’ to make it a small size (800 KB) and uploaded the same into the assets via Kodular Creator
  2. Generated the aia file
  3. Opened the aia file using WinZip, and replaced the ‘sample.3gp’ (800kb) file with ‘sample.3gp’ (20MB) file
  4. Imported the aia into Kodular again and generated the apk.
  5. apk was generated and when i install the app and test, i am getting the 'Error 701: Unable to load ‘sample.3gp’

aia file size - 20,540 kb
apk file size - 26,937 kb

I may be missing something here. Please help in clarifying and thanks a ton for your kind responses.

Did you even read the guides? This is not how it works.

1 Like

Hi, there were two options suggested by @bodymindpower, I have tried both…one using winzip and the other using apk editor and recompiling…still with the app I get the same error…I’ve read the instructions and followed…

Both methods should work, but there is obviously still the same bug that I reported already in July 2019. (Companion works.)
@Kodular please fix it.

if u search “Error 701 app inventor”, there’re so many people reporting this problem, not just Kodular.

@WatermelonIce Yes, iam aware, what’s your point? Iam trying to seek help for a solution…

just telling you that there’s no solution currenly, because it’s a bug i think as @bodymindpower says

The VideoPlayer component in AI2 (play from assets) is working.

1 Like

You will have to wait for a fix.

@bodymindpower i actually tried to Open the aia develiped in kodular using app inventor to see if i can load the video there, but it wouldnnt import…the otherway around works.

Max aia size is 10 MB in AI2.
So only “How to build a big app” will work.

See also here: