Urgent help - YAIL compiler - AAPT execution failed

Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/..
________Creating listview xml in res/layout-v21/..
________Creating xml in res/drawable/..
________Creating splash png in res/drawable/..
________Creating colors xml
________Creating styles xml
________Creating drawables xml v21
________Checking for firebase
________________Firebase components found.
________________Firebase config file successfully added.
________Creating provider_path xml
________Creating network_security_config xml
________Generating adaptive icon file
________Generating round adaptive icon file
________Generating adaptive icon background file
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
YAIL compiler - AAPT execution failed.
.

I am gettings this error, I tried changing the theme too, but didn’t not work, I may lost 9 month worked project if it didn’t fix, plz guys help me to get my project

error message alert : Build failed! Error: Your build failed due to an error in the AAPT stage, not because of an error in your program kodular

search the community

https://community.kodular.io/search?q=AAPT%20execution%20failed%20order%3Alatest

Taifun

I did this https://youtu.be/JphrpdBjg5k?si=2FtvcgYG_SMw5xt0

@Taifun plz help me, I am too scared, I don’t want to lose my 9 months worked project

@dora_paz Can I get your help

You won’t lose your project. Just do as Taifun said and go through the community. There is not one single answer to this problem. Search the community and check what works for you.

I tried 3 of them, but didn’t work

Then try the fourth :man_shrugging:

I am trying hope so to get my project back.

Or too lazy?
Backup your project
Probably you have a project inside yiur project? Try

Taifun

Or you can always share your aia, so someone can take a look at it…

Thanks for suggestion, But I fixed My self by changing the project and move the all screen to new project :slightly_smiling_face:

All you had to do was to change RTL=true in settings and reload creator…

1 Like