V1.0.5 Exoplayer for AppInventor | Play media with Google's Exoplayer

google drive video not playing pls help

Maybe this will help : Drive File Display Extension (FREE)

Hi Zain,

When I test the AIA for version 1.0.5 linked above, the blocks don’t load properly. Even for version 1.0.4. I did pm you on Telegram too. Thanks

Hello Zainulhassan ,

Please Help Me ,
Exo player resolution not showing

the aia file is for appinventor. You can open it up there and create the same blocks in kodular.

1 Like

Thanks! I will try that

Please some give me simple.aia file for this extension. I want to learn how to set blocks for this extension. Above given aia file are only for naming. All blocks are deleted inside the given aia.

Could you help me… Tried to start app with Exoplayer on Android 4.4.4. And got this error on start:

When Screen1 initialized, it just created Exoplayer in Horizontal Layout. On higher versions of Android it started without any error. But, I saw, that MinSdk is 16, so it should work. I’m sure, that this error related with Exoplayer, because same app without Exoplayer started well. Is it possible to use Exoplayer on Android 4.4.4? I’m using Appinventor, not Kodular.

You should set the min sdk to 21. This is because of missing functions in android 4.4.

What about PLYR? What the min sdk for it?

can any one show Me Same Example Blocks For My Help Basic

Extension not download


Can someone please help with this component method. I tried with “https://cph-p2p-msl.akamaized.net/hls/live/2000341/test/master.m3u8” url and its not working fine.

Please share a screenshot how it will work.

what do I do? so it’s giving error with exoplayer core

can anyone tell me how I can show subtitles

Just use the search function within the thread and you will get the answer. No need to make an extra Post


Why im getting this error


Can this affect the users,
Like android version 12,11,10,9,8,7,6

Please read

1 Like