Webview Doesn't work with html link

Hello, I’m trying to create a webview for my application that is in html, I will add the webview and it opens me very well but the internal links do not work, when I click the application closes, in my html links have links type : file///android_assets/ index.html but it doesn’t even work, I’ve been looking everywhere and I can’t find the solution


Upload that html file in firebase storage & use that link. May be its helpful…

It would be great, my app I also have it on a website, the thing is I want it to work offline

1 Like

ook but webview component never work offline. Either you use pdf.

1 Like

Webviewer need active internet connection to work.

You can create the html file directly in the “Load HTML” block using the join text blocks.

Something like this:

This way you don’t need an internet connection.

Since when

@adrianjael15 try this
App Inventor Code Snippets | Pura Vida Apps



It’s a good idea I also thought about that but my html file is composed of js css etc, and as I said if I work the visualization what doesn’t work is the internal links of the html when I click or close or it is to open with another application , it’s like it detects that it’s a file and tries April with an external application and I’ve already put follow link in both the webview option and the same blocks when I click you want to open with an external application

I tried that and the aia also i tried it I made the call to my html file and it opens it very well but when I click to open another link html does not work, even the same aia has 2 html files in assets and it does not work it seems that before it worked but now it is no longer worth

If Offline function as I said I said I open the html file very well with everything included and it works perfectly, but when I want to click a link does not work the link detects it as a file and tries to open it with an external application as I already put in the image

To open link in your app you have to use activity starter…

Try to do that too but it still doesn’t work, or maybe I’m doing it wrong, can you give me an idea how to do it?

1 Like

provide us your blocks screenshot.

Here I leave the single block, and the aia

HTML.aia (10.3 KB)

use taifun tools extension to get path to asset blocks.

1 Like

correct production path to assets (apk) is:
(not …/assets)

1 Like

If I’ve been over(s), but the problem is not that it’s not displayed if it works if you see me, the problem is this

That when I click on a link I get like this and don’t go to the other html file

If you’re right I missed the extra(s) but it was only in this test that works well, only when you click on a link the link doesn’t work

bro asset file link never work as URL in webviewer.

& one more questions its a pdf file or html …because in your screenshot their is pdf viewer to open that file but you are saying its html