Webviewer is not able to display an image from ASD

Hi, iam buying taifun pdf extension and pdf won’t display in web view, anyone can help?

anyone please/??

does the example project work for you?
btw. what about providing a screenshot of your relevant blocks?


number of page detected but pdf wont display

i just read in your web, that u upgrade the extension, is share link that u give me from email update too??


obviously you should always use the latest version, which is in this case version 2a… you can download it from the download folder


i use the latest version but pdf still unshown (not loaded)…
any setting? must apply to web viewer or pdf extension may be?

which version of the tools extension are you using?
version 21a is the latest version…


yes 21a, the lastest version of ur extension, but pdf wont display…any help? or setting guide? because i runing out of time

did you upload the html file page.html into your project?
alternatively as test you can try to display the rendered image in an image component to find out, if it is a webviewer issue…

yes i upload page.html
how i test rendered image??
can you explain with example block

i try with image component but pdf still not show…

test in android 11

The rendered image will be stored in ASD… you can take a look at it using a file manager like total commander

There are several example projects available in the download folder for you to try…

For example the downloadPdfKodular.aia


i try exactly like ur aia ( downloadPdfKodular.aia ), but pdf still not show…

as you can see here, the example app (which uses an image component to display the rendered image) works fine

and as we can see from your example blocks, you are using a webviewer…
I’m currently doing some tests using the webviewer to display the rendered image…
see also this thread Can't load html file to WebViewer from ASD - #9 by Taifun


my pdf location in file:///storage/emulated/0/Download/data/
is any problem with that file location??

the rendered page of the pdf will be stored in the ASD and from there it will be displayed
however I was not able to get it running, see the other thread… is it only an Android 12 issue? is it a general issue for Kodular 1.5.4? see again the other thread… also you might want to use the test project there and test it using different Android versions… I currently have only an Android 12 device…

PS: I now updated the subject of this thread…

Post the aia or better yet, a test aia that is as simple as possible.

see the other thread

PS: as this actually is a duplicate thread concerning the webviewer issue, I will close this one…

as workaround you can display the rendered image in an image component as shown here in post #13

we have to wait, until the Koduar team fixes the webviewer bug…

EDIT: I now used the workaround using the extension by @TimAi2

and have been able to display the rendered image successfully in the webviewer again…
Thank you @TimAi2 and @Groza95
@lanshamilk you can find the updated example project downloadPdfKodular2.aia in the download folder