After exporting the Apk and installing the application, I could not run it

In September 11, I exported my application (aia and apk file) to my computer, It was working like expected.
In September 20, I wanted to make few updates on my application, I generated the apk file and I installed it, However I could not start my application: it crashes suddenly after its showing the “Splash Screen” without showing the first screen.
It runs without errors in compenion.
I imported the old aia file in a new Kodular account then I exported the apk file without any update and I get a new apk file which has the same problem: It crashes after being installed and after showing the “Splash Screen” even when modifying “Minimum SDK Level”.
I use MIUI 11.0.2 (Android 8.1.0).

Since Kodular Apk generator gives one running Apk (In September 11) and another one which could not start (the new one) for the same aia file ( the aia file of September 11) I think that there are some update which cause this error.

Please advise.

Welcome to the community. Please check this


You have another account on the community. Which one should we delete?

I tried to update it by filling all the fields required in the given discussion but I had the same result: a failure just after starting.

I think that having one working Apk and other not working for the same aia file is a key point.
the first apk file that works:
MY_STORE_APP__911 .apk (8.1 MB)

The second apk that crashes:
MY_STORE_APP__V3_911-Not Working-.apk (8.1 MB)

They are build from the same aia file stored at 11 September.

I followed this post ( Last point):
" You can try all these solutions but the easiest is perhaps if your buddy who can upload the project in their account or if you have two account’s you can do it yourself .


I believe there are still empty fields which you have not filled please check once again

Here is your logcat

java.lang.RuntimeException: Unable to start activity ComponentInfo{io.kodular.my_store_apps_1.MY_STORE_APP_V3_911/io.kodular.my_store_apps_1.MY_STORE_APPV3_911.Screen1}: /tmp/1632334505482_0.5437768960139282-0/youngandroidproject/../src/io/kodular/my_store_apps_1/MY_STORE_APP_V3_911/Screen1.yail:2136:67: unbound location null
	at android.os.Handler.dispatchMessage(
	at android.os.Looper.loop(
	at java.lang.reflect.Method.invoke(Native Method)
Caused by: /tmp/1632334505482_0.5437768960139282-0/youngandroidproject/../src/io/kodular/my_store_apps_1/MY_STORE_APP__V3_911/Screen1.yail:2136:67: unbound location null
	at gnu.mapping.Location.get(
	at io.kodular.my_store_apps_1.MY_STORE_APP__V3_911.Screen1.lambda847(Screen1.yail:2136)
	at io.kodular.my_store_apps_1.MY_STORE_APP__V3_911.Screen1$frame.apply0(Screen1.yail:149)
	at gnu.expr.ModuleBody.applyN(
	at io.kodular.my_store_apps_1.MY_STORE_APP__V3_911.Screen1$frame.applyN(Screen1.yail:15)
	at gnu.expr.ModuleMethod.applyN(
	at gnu.kawa.functions.ApplyToArgs.applyN(
	at gnu.mapping.ProcedureN.apply1(
	at io.kodular.my_store_apps_1.MY_STORE_APP__V3_911.Screen1.$define(Screen1.yail:10263)
	... 11 more

Got exactly the same log , something is empty


I delivered Apk files generated from the same aia file which have empty fields.
If the second one crashes (Not Working version), the the first one should crash too(Working Version).
you should have the same Logcat then for both apk files.
should I complete filling in all blank fields and then export the apk file?

Yes please fill all those empty fields and compile.
You can refer the topic posted by @dora_paz

1 Like

That is two Kodular accounts, not two community accounts. So again since you think it is funny. Which account should i delete. If you don’t choose i will make the choice for you.

I created HADDAD1 account to resolve this problem,
I’ll delete it once I finish this.
Do you have any explanation for an apk that works and another that crashes for the same aia file?
the only difference is the Exporting date.

Thank you for the advice,
I filled all blank fields with values, and I had finally my running application.
but I did not understand the reason that let first application runs.
As a new user, I thank that a predefined values inserted automatically at sensitive fields could be a solution.

Have a good day.

I tried to Delete my Kodular account HADDAD1 but I had this message.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.