An error occurred while executing "bundletool build-apks" in the Android App Bundle sent

Hello people, when trying to create “new version” of the app, the following message appeared: An error occurred while executing “bundletool build-apks” in the Android App Bundle sent. Check that the package is valid. To do so, run this command locally and try again. Know more. Error: Found multiple elements for key ‘’, expected at most one.

I emphasize that the app already worked perfectly and is already in the “PLAY STORE”.

Thanks for any help.

1 Like

which extensions are you using?
several components or extensions might be using the same library…

Hello Taifun, as I said: The application works and is already on the PlayStore.

I see no reason to give this error, when I generate it locally, it does not show an error and it works normally.
I’m passing the image with the extensions I use in the app.

Please check, if one of the following threads can help
and let us know, what you find out


Hi, do you have ads in your app? If so, that was the problem for me.

I tried with AdMob extensions and with Google AdManager (from Kodular itself), but if one of them is used, I get the same error message as you in PlayStore - without ads it works…

About a month ago I was able to update the app normally in the PlayStore.

Ah, I just see on the screenshot that you apparently can’t use any ads in the app, because of the Free plan. Maybe the answer still helps (someone)…

1 Like

Taifun, I saw another user with the same problem as mine, I see that it is not an isolated case, will anyone from the company give a solution?

I also face same problem in my play console.

They are in deep sleep… it is hard to wake them up… :alarm_clock:


Same issue, any solution?

Searching the internet I found this:

“Delete this section: ************ Google Play Services Base ************
Already included in CreateResourceFromFile(Macro, FirebaseAnalytics.GooglePlayBase)”

But this is an internal problem between KODULAR and GOOGLE, there is no way I can interfere with it.

Hello Pirulito, how are you?
Did you already get the solution for the problem? Since you are premium, I think you should have a different treatment.

Hi, I have no idea why, but I can upload to PlayStore again without errors but I haven’t changed anything in the app. Maybe it was an error from PlayStore?

Hopefully it stays that way… I hope with you maybe it works again too.

But we cannot keep an app without being able to change it, in my case there are changes to be sent to the PLAY STORE.
It’s the first time I’ve seen a tool that charges for use and is full of bugs.
Nobody deserve.

My issue got resolved. Developer updated its extension & i was able to upload it to play console.

Remove Firebase Cloud Messaging extention and upload to play console
it works for me

1 Like

An error occurred while running bundletool build-apks on your uploaded App Bundle. Ensure that your App Bundle is valid by running bundletool build-apks locally and try again. Learn more. Error: Found multiple elements for key ‘’, expected at most one.

What can i do please tell me @Diego

Please check, if one of the following threads can help
and let us know, what you find out


It happened to me, in my case I was using admob and admanager extension in the same project, so I left only one and it worked.


while i am uploading my app in google play console i am facing this issue can anyone help me?

Iam also getting same…any one have solution?