An exact copy of a working AIA and app (apk), builds a non working APK

  1. Yesterday I compiled an aia-source tot an apk-app. I installed it and it worked fine.
  2. Today I opened the original aia and saved it under a new name (all valid characters). ok
  3. I compiled it to an apk. ok
  4. The apk of the copied source can be installed fine.
  5. After the installation the button ‘start app’ is grey. unusual
  6. There is no sign of the app, I cannot start it, but when I open the Android app settings, the app is visible.
  • To check the original source, I compiled it today and the apk works fine.
  • The copy of the source and the resulting apk fail as an app.
  • I emptied the cache of Firefox and started my Windows 10 machine again, to be sure it is not a cache problem
  • I tested aia and building apk also in Google Chrome browser, with the same result
1 Like

Check this:
I found it by searching “My app is not showing after install”, you can do the same. :wink:

Which will lead you to this post where @Boban posted the solution.

3 Likes

Thanks Italo for the clue of a missing line in the manifest (Boban).

< category android:name=“android.intent.category.LAUNCHER” />

Since I did not change the manifest, it is a riddle why this can be the case. I can decompile it and see if this happened. Meanwhile I have taken an earlier version and made the changes again. It compiles and I can make version copies. I know an ugly solution but it worked.

1 Like

:smiley::+1::+1: I had the same happening a couple of weeks ago.
Glad it worked.

The problem seems to happen when you make a “SAVE AS” of your app.

Well, if it is considered a mistake they should report it on GitHub

This was a strange one, haven’t hade this kind of issues

Btw, If you experience this at any time please post a demo.aia of it

1 Like

Have you tried this too?

That’s what happened to me and I found this solution which worked perfectly:
And @pavi2410 knows about it. May be there wasn’t time to fix it yet.

But this should not happen anymore as long as you don’t have a old aia file from makeroid time

In my case it happened the Koduloid game, which I started recently. And I never made an app when it was named Makeroid. I made a copy of it and when I tried installing the copy, the installation went OK but I couldn’t find the app anywhere, except in the Apps Settings.
I downloaded the aia, made this change from @7StarMedia and re uploaded it. After that the apk installed perfectly.
00
1

I would like to replicate this behavior but so far no luck

1 Like

I’ll try doing what I did.

1 Like

It is awful but again the same error is risen. My working aia and apk can be saved as a checkpoint, but the result of the copy will produce a non visible app. Checking manifest.xml the line < category android:name=“android.intent.category.LAUNCHER” /> is missing.
But I just copied a working file without any changes in Kodular.
What to do Boban because of this erroneous behavior?

Since @Italo experiences this with a new project however, I have to ask is it old or new

What to check, download you aia, open it with 7-zip or equivalent program

Check that you have only kodular folder, if you have ex. makeroid then move all files from it to kodular and delete makeroid folder

Go to \youngandroidproject\ folder and open project.properties.xml, check that it contains io.kodular as in the folder structure above, if not change it

As I mentioned the big post

I made this Kodular app from scratch in Kodular.
Checked the apk and there is no makeroid folder at all.

Check aia file

No sign of makeroid in aia project.properties

main=io.kodular.appsbeheerder.WoordSpel_v28.Screen1
name=WoordSpel_v28
assets=…/assets
source=…/src
build=…/build
icon=WoordSpel_logo.png
versioncode=28
versionname=1.0.28
useslocation=False
aname=WoordSpel++
sizing=Responsive
showlistsasjson=True
packagename=com.appsbeheerder.woordspel
onesignalappid=xxxxxxxxxxxxx
color.primary=&HFE5A72D5
color.primary.dark=&HFF303F9F
color.accent=&HFFFEC007
theme=AppTheme.Light
splashEnabled=False
splashIcon=TaalSpel.png
minSdk=19
rtlSupport=False
projectColors=[{“hexa”:“B2A4D8FE”,“freq”:“1”},{“hexa”:“8E9EA4FE”,“freq”:“1”}]
receiveSharedText=text,

Sorry I’m clueless

It seems that decompiling apk, adding < category android:name=“android.intent.category.LAUNCHER”/ > and (App2market) compiling it, is the only solution for now. A lot of extra steps, but if there is no other solution, it is.
I wholeheartedly hope, it is the only project that will show this behaviour.

Thanks Italo :green_heart: