App is not opening after install

Hi there. Once Kodular was updated, the app I have created is not opens after install. It installed fine but when I open it I get its properties screen (by the system) and not the app itself (as you can see in the attached video). Moreover, the aapp is published in google app store and the problem exists there too. after installing it, I don’t get the “open” button like usual, only the “uninstall” one (as you can see in the attached screenshot). Does anyone have an idea what can cause this problem?
Thanks a lot :pray:.


See play protect message “the app may not be optimized for your device”

1 Like

Thanks for your replay. I tried it on several devices and it works fine if I am using the Kodular companion for testing (by scanning the barcode).

please removed admob conpoment

1 Like

I do have Admob components in the app. Why do you think they cause the problem? And if so, what is the right way to use it?
Thanks :slight_smile:

It seems like your OS has some troubles with your app. I recommend make a copy of it (save as option)and rename and then installing .
help kode

1 Like

Thanks for the answer. I will try it. <3

It didn’t help :frowning:
I still get the same error.

Post your apk here

1 Like

MiHuZe.apk (9.4 MB)
Here it is.
Thanks a lot!!

Try this one, see if it installs and run ok

MiHuZe.apk (9.4 MB)


Yes!!! It works!!!
Thank you so much!!!
How did you fix it??

First of all min SDK for your app was set to android 10 but the main issue is in android manifest because is missing the Launcher intent filter
<category android:name="android.intent.category.LAUNCHER"/>
Did you remove the Launcher intent filter from activity in manifest?



I am not sure what is the “Launcher” or “manifest”. I might have accidentally changed it in the Kodular workspace? Where its defined (so I will know to restore the original settings)?
Where did you take the screenshot from?
Thanks again for the great help :heart:

Judging from your reply you couldn’t have done it. I decompiled your apk with APK editor studio to inspect it. I do not know what caused the problem maybe someone else might have an idea why this happened. If you wish pm me your aia to see if same thing happens if I imported aia and compiled it

1 Like

I sure will. Thanks!! :slight_smile:

Sorry for the Nuby question, but I am not sure how to send a PM in this environment? :see_no_evil:

For some reasons you have two different names in your app


Download the aia, move all content (if any) from folder you don’t want to keep, delete unwanted folder, save upload aia.


You are right! This was the old app name I had to change duo to naming violation with Play store rules (It was too similar to the name “whatsapp”). Is there a right way to change an app name in Kodular (without remaining like so)?
Thanks for your help :heart:.

I hope its acceptable, I PMed you the aia in Discord (I known there as Moozar).
Thank you so much!!