app is not working after apk installation

Hello every one,
i’m facing strange problems after apk installation in mobile though everything is fine with companion.
problem 1…
screen 1 has 2 button, when button click it will open another screen.
it is fine when testing with companion…but after apk installation in mobile , the app get closed if button click (problem with both button).
problem 2…
if the app is closed from screen 1 by back press, then again it open screen 1 with a single tap on app icon in mobile screen…but if screen 1 is closed by pressing mobile home button, then it takes double tap on app icon to open screen 1 again.
what would be the solution…

Hi @funtu,
First you are not switching screen correctly.See here:

You can see here:

Hi,
it’s a bizarre problem…if I use close screen instead of close application…now it takes ‘back press’ twice to close the app.
please look at the video as well as my entire blocks…may be problem is there even in app design,


Screen 1

Screen 2

Screen 3

Screen 4

Can you send this test aia?

sure…
test.aia (183.7 KB)

It should work according to your blocks but as you said it’s not working the try setting procedure as if true then close screen and after that open another screen check if it would work

I’ve already made that in this aia but it isn’t working,( i’ve withdrwan my post )

You are opening your screen twice

1 Like

Yes I just found the same that network connected block is causing the issue

1 Like

Sorty, but is @funtu :point_left: this your second account?

In addition, Is connected has been used twice! Do not repeat yourself!

Yes, but why is this event triggered only when the screen is closed / another screen is opened?
Usually this event is only triggered if the connection status changed:

grafik

Same question: why?

No, this is not the same. See above.

1 Like

Because when you launch your app it connects to network and thereby you are triggering both events…

bild

Try this one funtutest.apk (5.6 MB)

Then what would be the blocks…
post screenshots please…

You mean…just omit that,Network 1.On Connect block
if that then sorry it is not working…
in that case, if I open the app when mobile data off, screen 1 ,that is, ‘No Internet’ with progress bar is shown,but without leaving that screen if I ‘on’ mobile data ,it does not open screen 2.

Ok do it like this then

Make sure that label is not checked in designer as visible

No, this does not apply to the first launch of the app (but only if you reload the screen).

See here and check this APK:

test_NetworkOnConnectTriggered.apk (5.6 MB)