Bug: on on off buttons font cannot get bolder (probably italic too haven't tried that.)

Hey Everyone,

While creating a settings page for my app, I used the on off switch component and I noticed that the text won’t get bolder (probably italic too, I can’t say an exact thing for italic because I haven’t tried it yet.)

Has anyone noticed this too?

Could you send some screenshot of what you see, please?

all right, one minute please.

So here are the screenshots and the problem.
After I insert the switch component, I would like to make it’s text bolder or italic if I want, but when I click these buttons:


nothing will happen.

Here is my settings page UI and the Switch component (only for demonstration, marked with blue pen)

After setting bold text:

Before setting bold text:

The exact same. Text format (style) won’t change.

Note: No any custom fonts etc. has been set. The default font is being used. (Companion)

I have tested this feature and I can confirm that the bold and italic text doesnt work.

I can confirm the same. I try to fix it for next release.
Thanks for letting us know it :slight_smile:

btw… other fonts works.
It’s only the bold/italic setting that have a bug.


Yep, thanks @Mika :slight_smile:

1 Like

I have fixed now the isse for the next release.


Thank you :slight_smile:
Was fixing easy?

Yes. I forgot to add a needed line of code :joy: