Bug on WriteExternalStorage Permission - Not Working

Hi Taifun,

After a few days I will finally be able to work on the app to try to fix the error.

I did the “installation” of adb as instructed, but the device does not appear in the dos list

the usb debug is enabled, and I believe that the device driver is ok too (I don’t know how to check this, but I believe it is ok because I can transfer data between the notebook and the smartphone).

Just to let you know, the app compiles normally before the last kodular update.

But after the update, once again problems arose (I don’t know if for everyone).

The first image below is for you to see the “installation” of adb, and the second shows that the driver must be ok.

In the third image is the adb working.

What could be wrong?

Thank you in advance for your attention.



From the documentation

you need to use a USB cable and enable debugging on your device. Follow instruction HERE for enabling USB debug.


Yup. I did it. But maybe I did something wrong. I don’t believe it, but it’s possible. I will try again. Tnx

Hi Taifun,

You were correct (again). I had not enabled usb debugging.

Fixed that, I found error 908 in the log, and it started happening after the last kodular update.

I tried to fix it with the DeclareReadWrite.aix extension, but it didn’t work.

I read that google does not accept some of the proposed solutions.

I want to publish the app on the play store. Is there any temporary fix for this while the devs don’t fix the problem?

You dragged the extension into the working area?

See also here


Yes I did it. But error 908 still appears.

I did this too


How do the permissions in your manifest look like?

I don’t know how to see this.

I tried using the “apk editor studio” as Anke taught in How to customize the Manifest → example: Companion APK, but the following error always appears: Error unpacking APK.

editor error

That is, to fix the problem I always need to fix other things first.

This app worked fine. I needed to update it, and for that I even became Premium.

But I just can’t fix the problem on my own…

Well, this is another problem. Sorry for the rant.

Is there another way to check the manifest?

Also, this app is relatively new, and needs to be compiled in aab. But this is also another situation to resolve later…

in post #8 of that thread it is explained what you can do in case you get an error


1 Like

Taifun, I changed the Manifest as Anke taught, and now it works.

I Replaced line
uses-permission android:maxSdkVersion="29" android:name="android.permission.WRITE_EXTERNAL_STORAGE"/
uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE"/ .

Now the question is: How to change the aab manifest??

You don’t need to modify aab manifest Convert apk to aab now

first download the apk from https://github.com/sensei-z/APK2AAB/raw/main/Android-Tool/APK2AAB.apk

This apk is developed by @Shreyaa and its very good. I used it personally.

Here is an video

Also there are 2 questions regarding this

  1. Now its working fine in all android version also can you please share your permission blocks.

  2. Also do you use that bodymindpower extension to declare permission in manifest?


Yes, I do it

I used apk2aab and was able to generate the aab file.

But I couldn’t install the package.

Do I need to use ZipSigner too?

In the video I didn’t understand what it’s for (I don’t understand this language).

If I need to use it, where can I find the package to install?

I couldn’t find it on the play store

Thanks in advance

Yes you have to install the android key in that aab.

Download key from Kodular - Preference- Export key

ok. Now i have the keystore exported from kodular.

do you have the zipsigner apk?

AABSigner.apk (1.1 MB)

Here is the apk

4 posts were merged into an existing topic: Firebase authentication not working in Android 11+

Tnx a lot, @Yash_Agarwal

1 Like

Hello everyone!

I tried to use APK2ABB but it doesn’t work with my Apk.

Do you know of any other option? I need to convert my Apk with its new manifest to Aab to upload my update to Googleplay.