Cannot gain permissions


I need some help regarding PERMISSIONS.
I cannot gain any permission via block " ask for permission";

For test i did one simple app with:

Bind to screeninitblocks

Upon start, app did not give any popup message to accept them. It writes error notification, that permissions are DENIED and to go to enable them from APP SETTINGS.

In app settings are NO PERMISSIONS REQUIRED ( all are empty )

I placed only one button, which starts:

dumpsys display - require DUMP permission. So the return of the shell was “permission denied”

For separate test, i made one extension, where i declare those permissions. They ware written in AndroidManifest.xml … but again not triggered or applied. ( maybe I am missing something )

I tested on several devices and androids. Nothing … :slight_smile:

Even this is not activated:

I am stuck for several days on this issue :frowning: and I need some help/advice.

Thank you in advance!

Did you search the community?

We have a lot of topics about that.

Yes, all topics and the result was the same.

Also i tried with full permission name in the block - same… nothing.

Just follow the tutorials Peter showed you. Because the blocks you show have nothing to do with the procedures provided in the tutorials

1 Like

never heard of that.

1 Like

See here:

You totally misunderstand it… it wasn’t a must


ok…Then it’s not a must to add androdid.permissions to the permission name :thinking: Ok thank you :+1:

@Vlad To request permissions, they must be declared in the Manifest.
As a rule, this is done by the respective components / extensions that add the pemissions to the Manifest.
So which components / extensions do you use?

@ bodymindpower,
I found the issue, why are not working.

I had made one extension at appybuilder.ide to declare permissions. (no extra functions in it, only declare ).
But the problem is, that commands I had used are send via Shell component. And those perms are not applied. I should try to make some more fully function extension for DUMP and HDMI_CEC. Maybe will gain some success :slight_smile:

I use Android TV Boxes + normal TV attached to them. To can control TV whatever is ON/OFF/STANDBY i need to send commands to HDMI-CEC. It can be done in shell via commands.
In TvBox shell ( with SU ) i have access to DUMP and to HDMI-CEC cmd . But in app SHELL no. TvBoxes are not rooted.

So now i am again on reading … how to write it :slight_smile:


So, some permissions cannot be gained, even are in manifest and asked.
In my situation with Android 9 and TV Boxes i had managed to give access to DUMP permission via shell.
pm grant android.permission.DUMP

Also by root i did the rest, to give access to hdmi-cec ( /sys/class/cec/cmd ) access to all apps.

For now my issues are solved. All works fine (for now :slight_smile: )

1 Like