Compiling stops at "Compiling source files"

I have been coding this app for a school project, I have been coding for the last 4 years in several laguages, but I only started to use kodular for the last 2 days.
I have spent a lot of time in this last 2 days making my app and making sure that it would work properly because it is suposed to be presented to our school group principal.
Now on the companion worked flawless but when I went to export it, it would give me an internal error, to wich I removed some extensions that could be causing that, then the problem was fixed, but it gave me another error:
Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/…
________Creating listview xml in res/layout-v21/…
________Creating xml in res/drawable/…
________Creating splash png in res/drawable/…
________Creating colors xml
________Creating styles xml
________Creating drawables xml v21
________Checking for firebase
________Creating provider_path xml
________Creating network_security_config xml
________Generating adaptive icon file
________Generating round adaptive icon file
________Generating adaptive icon background file
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
AAPT time: 1.744 seconds
________Compiling source files
The only extension that Im using is ImageViewer extension, that I have removed and the issue did not resolve.
The app is suposed to be a student tool, that you can upload your schedule, your shcool plataform info, know where are your classes.
I also had made a previus version that I installed on my phone, the changes that I made where just on the 5th screen.
Here is my project, please help and thank you.
SearchProject.aia (983.5 KB)

Search the community for compiling source files


1 Like

check this Something went wrong! compiling stuck at "Compiling source files" - #4 by Boban

1 Like

I think it might be a project in a project, Boban said it on another post, and if that info is up to date its my issue, Im compiling now, and its not giving me that error. I will Keep you guys updated.

So… It did compile, but as soon as it finished and I tried to open the qr code it said that the link had timed out, I will do it again.

It’s done guys!!! Thank you for your help, here is my fix:

So, I downloaded 7-zip(Link for it is here, then I just did what Boba said, Open your project file with 7-zip, open the folder “assets”, and then open folder “external_comps”, if you find inside of this folder the following foldders “assets” , “scr” and " youngandroidproject" just delete these folders, MAKE SURE TO MAKE A COPY OF YOUR PROJECT BEFORE DOIS THIS PROCEDURE, just in case if you do something that you shouldn’t.
I have no clue why did type of problem appened, if you know something, let me know.
Happy coding!!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.