Date Not Show Properly

I Saved Date in Spreadsheet Column in DD-MM-YYYY format but when I show it in app, it convert into YYYY-MM-DD format.

Will you please teach me how to solve this issue?

Show the blocks you used to display it.

It is as Regular we use.
call Spreadsheet to get cell
When Spreadsheet get cell > Set Label1.text to GET VALUE
block

I also tried without JOIN component but result is same

i don’t know why this is happening that you insert data in other date format and display in other date format… but if we can change date format very easily from below block–

1 Like

Maybe you have set date’s default format to yyyy-mm-dd so airtable automatically formatted all dates in that format.

And @nikzdreamer2001 you are doing well.
Your blocks seems to be correct and should work.
But I have a suggestion and question for you.
Use of segment block makes it a bit complex.Instead of that you can use select list item block.
The question is that split block returns a list or an array?

no it just remove any text and creates space there…
i have tried that…

Let’s have an example.
We have a string like this:
a-b-c-d
Now if you will use split block then it will be converted to this:
( a b c d )
FYI those are not spaces.This is the format of list in AI2.
Give it a try and you can find it yourself… :slightly_smiling_face:

i don’t know about that… :stuck_out_tongue_closed_eyes:
from next time i’ll remember about that…

but if we use list then we have to use select list item everywhere otherwise date 21 will become date 12…

Sorry…Can you elaborate it more?

i’m sorry i got little confused as i supposed if we split date 2020-03-21 then it will become (2 0 2 0 0 3 2 1)… but result will become (2020 03 21)
i got confused in starting :sweat_smile:

This would be the best way to achieve the result…