Error 1103 - post text

Hello, I want to mention that I have conducted extensive research on the error I am about to discuss. While some people attribute it to the SSL certificate, others have been unable to provide a clear answer.

Here is the issue I am facing:

I have developed a relatively simple API to connect the form I created using Kodular to my online database. I tested the API using Postman, and it functioned properly. However, when I attempt to submit the form data, I encounter the 1103 error.

Here’s a portion of my code.

I would greatly appreciate any assistance. Thank you all in advance.

Are you sure, your API expects a Post request?
The way you are sending your data let’s me assume, that your API expects a Get request…

What about providing the working Postman solution for us to check?
Also the php script would help…


Portion of the php code:


Send your data as dictionary

See chapter 1.2 there


Taifun, I sincerely appreciate your assistance, and I will gladly implement your suggestion. I will return later to share the results with you.

Taifun, I followed the advice but still no progress. Do you spot anything obviously wrong?

Print screen

Best regards.

What you are showing us looks fine…
You are hiding the dictionary…
Also how does the Web GotText event look like?

The snippet with the dictionary

But the weird thing is that this event isn’t being triggered:
Captura de tela 2023-06-05 174907

The url variable:

Captura de tela 2023-06-05 174848

Have you tried using some of the suggestions given as a solution here in the community?
The POST sending is ok, what about the return? Have you tried putting a var_dump($data) or $json and die() in your script and checking what the error is?

localhost does not exist
Try using the ip address