Error 908: The permission has been denied

Good afternoon,
Before compiling on the new version of Kodular Fenix, I was using a Version 11 Android device with no problem. After I compiled it in the new version, it didn’t work anymore and a permission error appears as shown in the captured image. However, I have already enabled all these permissions in the app. I thought that it could be the use of some extensions, but I’ve run the recast and saw that all extensions were already ok, as shown in the image.
After racking my brain I decided to install it on a device that has Android version 5.1.1 and it worked normally.
Could anyone tell me if this really is the problem of the Android version?


Did you try enabling these permission in settings app?

Hi,
Yes, I have enabled permissions in the app settings.

i am also gettin the same error after fenix update
this is because of runtime persmission like [email protected]WRITE_EXTERNAL_STORAGE

Well, I still haven’t figured out why my Android 11 device displays this permission error when I try to enable these permissions internally in my routine. But debugging my application I found that the Device_Utilities component is not firing the Device_Utilities.GotSerial event when I use Device_Utilities.GetSerial. In the version prior to Kodular Fenix, this event was fired normally. Any suggestion?
Erro2

On Android 10, device identifiers began being protected. This is because people aren’t supposed to store them in databases (like you all probably do.) With Kodular about to target API 30, this method wouldn’t work anymore anyway. It will still function the same way for devices running below Android 10.

Understand. But it didn’t even return a null value. The event did not fire.

It’s possible that that’s don’t purposely.

They could leave the option to use the old version until we fully migrate to the new version. It’s not easy to look for the error and have to change the routine.