Error Build, need i little help :)


First, sorry for my english !

Well, i had created a application (with authentification, chat, etc…) and i have a error when i want dowloade it (or QR code) i have error : 0% something wrong. If i try again, not the same : i can have nothinbg show or a lot of thing… Someone can help me please? i put my AIA file .

GroupeV6_5(1).aia (2.1 MB)

I don’t know if there are other errors with your app, but I found these 3 errors :point_down:

  1. Your Package name is in wrong format. Currently it is :point_down:


It should be in the format com.example.appname

  1. Whenever I load your aia below error appears

  1. At-present there are 11 screen in your project. Using different arrangements and toggling them as screens will prove helpful

Hi @JeS_appelle_GROOT Welcome to Kodular Community

Make sure you have uploaded json file.

Click on Show Log button and then post the result here.

Hey, thanks for the reply, i change the app name package on Groupe.V6.5 still error, i take a backup with the thing who missing (Vaibhav) and it still not working, i have these error now when i try to make a QR code

and the error appears just after :"drawing the icon application)

Remove icon and see what happens.

1 Like

i don’t have icon :(…

vivekjain, it’s normal who it not working so?

Yes the issue pointed out by Vivekjain is happening with many project now-a-days, but it doesn’t mean that your project has no issues. May be there is something in your project that is stopping you from getting compiled. You need to be sure that there are no errors with your project

2.1 mb is quite big.
I think something is wrong with your project.

Oh…i don’t have idea… can you check the file please (if you have the time), i have some screens who are not finish, but i really don’t know :confused: GroupeV6.aia (2.2 MB)

Now it gives me Firebase config file error. Upon searching the community I found this reply by one of the user :point_down:

In this reply the user tells that the app’s package name and and the package name you provide in firebase should be same.
Now since you change the package name in your app, you may need to change the same in firebase and then create the json file.

Apart from this, I still think your package is not in proper format. Why don’t you keep as the format provided?

Oh ok thank you, i modified some things :slight_smile:

But now i have error when i try to make a QR code : ddddd

I had delete a lot of screens (those ones who are not finished etc)

I searched community for Preparing application icon & I got following result

See if it helps or just initiate a similar search to find other results

Mhh ok, it not working, but i think it’s the server :


this is the server?

If everything is done, try again after sometime

I have the same problem from a week…

I’ve searched in different posts and made many tries.

However I just have to do an update of my app (I haven’t changed practically anything, just added some data like labels and checkbox) but it just doesn’t work.

This is completely different from the discussion going here.
Search community for AAPT exceution failed. It has been asked many times before

1 Like

Actually sometimes I get the AAPT error and sometimes the one posted by JeS’appelle GROOT, randomly.

I thought it came from the same problem, that’s why I posted here.

I have searched in several forum threads but no solution has worked.

I don’t even have firebase in my app, I only have two extensions of Taifun and that of Dynamic Components.

I have tried with:

  • browser restart
  • icon deactivation
  • changed browser
  • Reset Connection before trying again
  • export and re-import the .aia file

No result.

This aia builds without a issue if you change package name to be the same, in both google-services.json file and on screen package name property

This is what you had in json file and as you can see they mismatch

        "android_client_info": {
      "package_name": "Groupe.apk"


This works

        "android_client_info": {
      "package_name": "groupe.v6.5"


1 Like

This means @JeS_appelle_GROOT didn’t checked properly :expressionless: :roll_eyes:

1 Like