Error from companion: cannot find the component Package_Utilities

Hi all, after the latest companion update (1.5.3), I am getting the error message “Error from companion: cannot find the component Package_Utilities”. I didn’t have this error before, I tried a new app by inserting that component and I don’t get the error, I just try to get the package name and version. I also tried to re-insert that component into the app where it gives me the problem, but it doesn’t fix. I attach image. Can you help me ?

immagine

maybe have a look at this

Have you updated the companion to latest version 1.5.3 cause for me it works with no errors

image

image

it works for me


image

If companion’s version is not 1.5.3 try to update it

1 Like

he is using the latest version

Hello everyone and thanks for the replies. Summary:
Using Companion 1.5.3.
I am working with the companion, so my “packagename” is that of the companion (however the “packagename” of the app I am testing is com.enfandroid.itemverifier, which is the one used and working until before updating the companion).
Interestingly, if I create a new app and the text with the companion, it works for me. It’s like it collides with something in that app.

I understand that if I disable the event that queries the packageutilities component, I get the error that it does not find another component, taifun ftp component, but I believe this happens because it is the first one that queries in my procedure, after the packageutilies that I have disabled. I exported the apk and this works fine. This is a problem with the companion version 1.5.3

Try reimporting the AIA.

1 Like

I am continuing tests to understand my problem, which is blocking me. I tried to create a new app and insert the TaifunSqlite component “Error from Companion: Cannot find the component”. Does anyone else have my problem? I work with companion 1.5.3, android version 11.
@Taifun Have you had any other reports?

I just tested this and the companion app opens fine for me… on Samsung Galaxy A51 running Android 11…
did you already try to uninstall the companion app and install it again?

edit: also Package utilities work fine for me…
Unbenannt

Taifun

1 Like

Hi @taifun, I created a blank app, I only have your extension inside, no events. When starting as a companion, it gives me this error. I tried uninstalling and reinstalling the companion. Android version 11 RP1A.200720.011

I now can reproduce the error… I will have to provide a new version of the extension…
I will send you the new version in a PM… please test… thank you…

Taifun

Hello everyone, the problem was solved by @taifun apparently the problem seemed to be with the packageutilies component, but doing some tests I found that it was caused by the Sqlite extension of Taifun, which after the last update (version 1.5.3, I assume ), caused problems. Taifun provided me with an updated version of its extension and I was able to fix the problem. Thank you all.

4 Likes