Google Connect button

I turned my website into google app. However, google connect does not work. What should I do
google link button site embedded

what exactly is Google connect? Please elaborate…

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select “Download Blocks as Image”. You might want to use an image editor to crop etc. if required. Then post it here in the community.


1 Like

My app only one web viewer page
This Google Connect button

After click

Facebook works perfectly.
But Google doesn’t work

what should I do?

I think this extension could help you

to detect that deep link and to use the activity starter to open a browser
the author of the extension @vknow360 might want to explain, what exactly needs to be done…


1 Like

Hi @Taifun
Probably @lubunyanet forgot to set user agent.The UA of webview is quite old and modern websites does not support it completely and Google is one of them.
My tests show that Community also needs a modern UA.
So he/she should try setting user agent of chrome or Firefox.

i don’t know how to do this

an urgent solution is required for this problem

You have to set user agent of webviewer to a modern browser’s user agent.
See here:

thanks, the problem is solved

Sounds good.
Then close this topic by marking appropriate post as solution :slightly_smiling_face:

1 Like

i pasted

Mozilla/5.0 (Linux; ; ) AppleWebKit/ (KHTML, like Gecko) Chrome/ Mobile Safari/
in User afent of webviewr but still the error occurs.

Whenevr I try to login through google. it says that it is not authorised please use browsers like chrome and safari

Because Android version , device name , build tags and chrome version are missing in your user agent.
You should check this:

I used this too but same error is displayed
Mozilla/5.0 (Linux; Android 5.1.1; Nexus 5 Build/LMY48B; wv ) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/43.0.2357.65 Mobile Safari/537.36

Can you please post what worked for you @lubunyanet ?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.