Help! Motto: Start Phone Call on Loud Speaker using "Activity Starter", Activity starts but Loudspeaker not

I want to initiate a Phone Call in Loud Speaker, My blocks are in below,

Activity starts as wanted but Speaker doesn’t turned on by default,
Please, help me someone to identify my mistakes… I will be thankful to you…

Read the blocks description. The Extra Value block is DEPRECIATED.
You can also get to know more about blocks from

Put Extra value blocks in top first take permission and after work.

Even now, not working.
(But it works using google assistant with voice command " Call -xyz- on loud speaker") - it is actually possible, But I am unable to find it till now.

Not working. As per my knowledge, blocks order is independent except “Start Activity” (should be at last)

The activity starter component is not able to send boolean values…
Try the activity starter extension and read the small documentation how to send boolean values there…



It’s not working even now
Call is getting connect but Loudspeaker is not activating

did you rename the extension?
it looks like you are still using the activity starter component…

to send a boolean value correctly, use a text block together with the text true
another thing you can try for the boolean value is 1 (for true)
see also How to fix the size of crop - #11 by andreapetricola



Tried almost every possible combinations, its not working till now…

it might be, that is is not possible in blocks…
you might want to write a small extension… see this snippet

EDIT: as I can see, you already tried a few things…


1 Like

I tried almost everything of my capability and even learned a lot in this process. I think this project could only be completed by a experienced coder.

The above code works only on my “ASUS ZenFone Lite L1” and is unable to serve its purpose on any other phone tested by me (approx 14 mobile).

According to my research
Google assistant with voice command “Call -xyz- on loudspeaker” works very well. It is working means we could achieve that. That’s why I tried using Intent. But, you know the result… and I tried almost 15 playstore & 5 other source apps but failed to resolve the issue.

I am waiting for someone who can help me as soon as possible…

And thanks a lot for your precious time and help @Taifun

You see, we do not have control over whether other OEMs have modified their software to remove this functionality or they might require additional undocumented permissions.

1 Like