How to update app through firebase?

I want to create app update, however it is not working. Kindly check screenshots and let me know why? Note second screenshot denotes “When screen1.Initialise tag”

2020-04-22_130027 2020-04-22_130058

Here are the full working blocks from my project.


In Activity starter data uri use your app link

Firebase value should be in format as your app version name format. Ex. If version name is 1.0 then firebase value should be 1.0 or 2.0 like this.

1 Like

If your app version matches with firebase value then no notification will be shown.

If you change firebase value greater than your app version then app update notification will be shown.

Hope this work for you.

which one is my project bucket (as per above screenshot)

Your project bucket is - App

Do same as in my post.

Bucket - Update
Tag - Update

done but still not working. it works with companion or not?

No. You have to check it in real apk.

Not possible. I am using this and working fine with me.

Your are doing something wrong.

Show all relevant screenshots as i shown in my post.

error : Bad arguments to>
The Operation > cannot accept the arguments:, [empty-string],[1.0]

1 Like

Your are doing wrong with firebase.


I said all relevant screenshots. Show firebase designer properties, your app version name

See your value format and mine.


Make correction and try again.

My friend, it does not make any diffrenece since both are more than one. As per logic set, app will match both, and in case greater than current found, it will proceed further

2020-04-22_141556 2020-04-22_141630 2020-04-22_141707 2020-04-22_141741


Have you made corrections in your firebase as i shown above post?

yes, still same error
error : Bad arguments to>
The Operation > cannot accept the arguments:, [ empty-string ],[1.0]

I got the error.

Your firebase url is wrong.

Close your firebase site. Re open it. Without clicking on app copy firebase url and paste it in firebase properties.

Use only this url. Or just remove the last “App” from url.

is it because of this only? why second red box is empty?


Yippy, it is working now

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.