I don't know how to use 'REST API file', I Need your help


I don’t know how to use FILE in REST API.
I tried several methods, but it doesn’t work.
I need your help. please

Please help me…

you might want to try face rather than text
also it might be necessary to use a full path like this file:///storage/emulated/0/01.jpg
is the a link to an english documentation available?



Nice to meet Taifun
I tried to your mention, but same.
Please check the web page.


maybe try what @Taifun said

you could try to load the image from the internet…



There are two ways.
Internet link works normally.
I want to use this API by taking a picture with my phone.
So I need an API to upload files.

  1. internet link (working)

  2. file (fail)

Can’t you just set an image to the photo you take and use that?

Like: image1
When photo taken set to image1
Set picture to image1

If the link works normally, the only thing I can think of is to upload the picture to Cloudinary, than call the API with the returned image URL.

if you get the solution to load the image from the internet working, then after taking the picture you can upload it to the internet somewhere to use that solution, so what about



i found it something
is it The -F file?
somebody know how to use -F ?


your latest version was fine… however you found out, that is does not work…
and somehow it does not look like you want to follow my last suggestion…
so unfortunately we are stuck here…


I just have seen, that the internet link is working for you…
so what exactly prevents you from uploading your image to somewhere in the internet and then use that solution?


I want use OCR for korea company API
I thought about using other OCR APIs
I am worried about the recognition of korean by using another OCR.

use the working solution
and: multipart/form-data is not supported in App Inventor and its distributions


That means about i can’t use multipart/form-data?

Did you check this api via postman

i dont know postman
can i check with postman?

Yeah postman is best for checking apis with all method

maybe… API is working
When tested with a PC and phone using a Chrome browser, it worked.