I need help with this: "Lookup in pairs: the list (Banana Abacaxi) is not a well-formed list of pairs"

I’m trying to repeat the search method for the image list component (This: Search for listview with image - #3 by Diego), but I get error mentioned in the title . I do not really where it comes from and how to solve it, so I ask your help :slight_smile:.


Filter_List_View.aia (15,0 KB)

you have to use a list of lists for the lookup in pairs block to work


I do not understand very well what you mean…

I tried this, but besides the list stay “(Banana Pineapple)” and “(Potato Avocado)”, when I search for one of these I get the result “not found”.


In the Not Found Make a List Like Global Lists

Sorry! I do not understand what you mean :confused:.

In the Not Found Block. Remove the not found text block and add a make a List Block there. In the First Slot add the Text_Box1.Text and in the second Slot add Not Found Text Block

That did not change the outcome…

Was that what you suggested?

No, This is not what i suggested. I will send you the blocks image. wait

1 Like

What’s your Current outcome? What is it showing now

“not found”

What do you want to be shown?

I want the list to be displayed correctly and the result matches the one in the list, but the result will always be “not found” regardless of whether or not the item is listed:

Search for Banana instead of (Ba. Dont use (

Curious, when searching for “Banana” I get this error:
When searching for “Banana Abacaxi” appears “not found”.

Because Abacaxi is a not list

But this happens when I search for “Banana.”

Are you Looking to make Something Like a translator?

No, I’m building a Notes application, I need a search function, but the default listview search bar does not please me, so I’m trying to create my own custom search bar…

You should take a look at the hint of the method setListViewElements. It takes a LIST of elements as input, not a STRING as you are trying to pass, since “look up in pairs” methods returns a string. Try to put the result in a list. Obviously you have to search keywords without the parentheses, as it’s already been said. They are used only to represent lists in Kodular, they are not part of the lists.

Ah, I thought that a list of corresponding elements was returned, well, I tried that but when searching for “Banana” the result is “Pineapple”, I want to be presented with elements that contain the letters searched, how do I do this?