In-App Purchases not working

[*] I checked out Bugs in Kodular Eagle before creating a new topic

Describe your issue

Hello :smile:
I was creating my app which is to sell gift cards online and then i added In-App Billing component to purchase packs of coins to buy gift cards, but the problem is that the In-App Billing is not working! The product id is a value that the app gets from Firebase Database
Here is how it looks like :
1 :firebase:
2 :google_play:

I tested it on different devices but still not working :sweat:
But while I was testing it worked two times or three perfectly then it don’t work again :worried:
Please can anyone help me I need to fix this as soon as possible :persevere:

If you created a new id in the play store u has to wait 4~6 hours till its will work but nowadays 1~2 days till work :frowning:

your screenshot is incomplete
which result do you get in the AfterPurchase event?

@Taifun The purchase window of Play Store do not even appear so there will not be any after purchase event working :persevere:

@DiSs No the products was created from 2 weeks :disappointed_relieved:

your screenshot is still incomplete

what exactly is the value in the example?
what happens, if you test it without Firebase?


1 Like

Even if I test it with text block without Firebase it don’t work I tried almost everything :pensive:

without a complete screenshot of your relevant blocks nobody will be able to help…
another guess: are you testing your app in Google Play Beta or Alpha?

I’ll send you screenshots sorry :sweat_smile: :pray:
No it’s not published on Play Store :google_play: :neutral_face:

how do you think you can test without publishing it in Google Play Beta or Alpha?

I tested it while it’s not published on Play Store it worked two or three times then it don’t work again :sweat: