In companion does not load all components

Hello, I have been trying to connect with the companion by USB or QR for 2 days, and it does not load all the components, try in another browser and neither, in another network and neither

it should look like this

and it looks like this

I see that I get this message

List out the components or extensions you are using…

Yes please list them and also have you tried it in a blank project?
By seeing the images I think your companion is unable to load image files.

Yes it may be because companion encounters an error before it loads the files. So the companion stops there.
The error is mostly due to an extension

I tried everything, I did a blank project and still, I changed computers, I went to another network, I deleted the data of the app and the browser and nothing

I think u r also using @Shreyash phase extension ? Right?

What do you mean ?

What about this?

I already did it, but the strange thing is that it also happens in blank projects without extensions

Are you using the beta version if the companion? As far as I know, it uses the new androidx support library, however, the creator is still using the old support library, which could cause NoClassDefFound errors, since the old support library classes aren’t compiled with the companion, and therefore the class isn’t found… :thinking:
P.S: that might be tye reason a blank project doesn’t work, since the same would happen with the screen component… perhaps you could try using the production version instead?

1 Like

This is a blank one, it only has what you can see and it does not load it to me.


I think it could be that, I’m going to review and tell them

Thank you very much, was this the problem, I hope they will solve it soon

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.