Issue regarding Pollfish

Pollfish team has reported that the SDK Kodular is using is not up to date and also has some bugs. This is the latest statement by Pollfish team, thus please check before pointing out the update 1.4C.2

@Prografellow You need to explain what you mean by “some bugs”.

When was your app developed and published? Version 1.4C.2 fixed the issue with one of the event blocks

1 Like

Pollfish’s most recent statement (10 minutes ago) mentioned that due to some bugs present in kodular, Pollfish is unable to deliver surveys.

@Prografellow You didn’t answer my question about your app creation date / release

1 Like

I have created my app before the 1.4C.2 update, but I deleted and added the Pollfish component again after the update.

V1.4C.2 fixed the issue. Did you experience any issue after this release?

Yes, I am currently facing the issue.

Please explain what specific issue you are referencing and also show relevant blocks.
Also, you can put together a simple .aia to show the issue.

Just saying that you are facing issue, doesn’t really help :slight_smile:

pollfishtest.aia (2.1 KB)

Of course your code won’t work because of following issues:

  1. You in NOT in test mode, so it won’t work in companion

  2. You didn’t specify ANY API key. You can use this API key and see result (make sure you check TestMode) : Pollfish Sample API Key: 2ad6e857-2995-4668-ab95-39e068faa558

First - I’ve used API key in my one. That’s just an aia showing the blocks I’ve input.
Second - I’m talking about final app, not companion testing.

I updated your .aia. Try running it:
pollfishtestTest2.aia (2.4 KB)


Your aia worked extremely well, what doesn’t work is my API key. Any advices? :slight_smile:

May I know the settings? Well I’ve already gone through the tutorial and checked whether I’ve done it right.

Not sure what you mean by settings. I posted the working aia

When I said settings, I meant Pollfish settings.

The .aia that I sent was was tested using companion.
The API key is a sample API key that was provided by Pollfish.
See my earlier reply about TestMode

The pollfish settings I’m talking about is not its properties. I am talking about the App Settings in

Thank you so much @Hossein for helping me get out through this error. It is solved :smiley:

1 Like