Kodular hangs at "20 Establishing Secure Connection"

i did have the same problem. but i changed to Mozilla Firefox. Then all working fine! You should try to change and use Mozilla Firefox

I got a new chrome update pushed to me yesterday and now the Kodular compiler doesn’t hang at 20% any more. But, I’m keeping my Firefox close by, just in case.

1 Like

Downloaded Chrome to check and your claim appears to be false. On Chrome and Edge 89.0.774.68, I keep getting…

And then failed XHR requests to Rendezvous. I haven’t tested with Firefox, but it apparently works from the replies.

My claim isn’t false, I just got a working update. Firefox was my workaround too until I didn’t need it anymore. Sorry to hear you’re still having issues.

FYI… WORKING Chrome version is 89.0.4389.114

It doesn’t work for me, and I’m sure many others could attest to this. I’m not going to argue over which Chrome versions work and which ones don’t, therefore I will stop replying to this topic to prevent further aggression from both of us :)

also having same issue in my pc and phone using latest updated companion and updated browser chrome, brave and Firefox in mobile and pc tried after reinstalling companion too but still same issue hangs at 20%


Only have to use Firefox browser for now can be bearable as it is working in it flawlessly. But kodular have to short out the reason why its not working on other browsers

1 Like

Ok, but you can’t argue with success. So I’m hoping that those “many others” will try it and also have success. Sorry you’re experience was different.

I ended up having the same problem,

I use opera, so far it has no problem. but since opera Version: 75.0.3969.149. Bulid application stops at 20%, then I try to use Chrome, the result is the same, then I try to use the tablet and it doesn’t have a problem. I assumed my opera was hit by some kind of malware and finally I factory reset but the result is the same. the last step I tried firefox and voala creator kodular worked properly. I use firefox 87.0 64 bit.
I hope it can be a solution for you.

not working for me (20 establishing secure connection) stock on that after nothing happen all kodular servers are looks good on status.kodular.io but I tried all method

  • clear browsing data
  • re install companion
  • connect with the same internet

The solution is to use Firefox until a more feasible solution is found.


When I am trying to use kodular companion it shows “20 Establishing Secure Connection” and stopped on 20%. I am trying to resolve it by using different browsers like chrome, microsoft edge, and Opera Browser. But still I am getting 20 Establishing Secure Connection
How can I resolve it??

1 Like

Look through the topic for the solution, then get back to me.


How about reading through this thread… it’s mentioned hundreds of times


(this post is for people who want to use companion app with Opera, I hope it can be useful)

Guys I use Opera browser and for me companion app has always worked perfectly, but few days ago I did the browser upgrade (to 75.0.3969.149 version) and companion app didn’t work more. So, I tried a lot of things but the only solution is upgrade Opera to the previous version and now companion app works great (but I have blocked the auto-upgrade of Opera, you cannot do this by Opera’s settings, but how below tutorial explains).

The Opera’s version I use now is 74.0.3911.75
You can find it to the end of this web page: Index of /ftp/pub/opera/desktop/
You NO need to uninstall Opera, just download the version above and install it, then NO open Opera, but follow this tutorial that explain you how to block Opera’s auto-upgrade:


1 Like

There was a fix pushed to MIT AI2 on GitHub a month ago that should ship with the next Kodular release.

Continue using Firefox as I haven’t found there plans for them to implement RFC8285.


Yeah, It would be fixed in the next update. As @pavi2410 and @Peter said.