Listview with Airtable error Attempt to get item number 1

Hi Folks.

I’m noobie on Kodular

I Made an App but is showing a error when listview load, I tried to do modifications but without succes

Attempt to get item number 1 of a list of length 0: ()

Thank you so much your help :slight_smile:


it is due to slow update of the airtable value into app. use clock timer.

Use get column blocks before global conter

Hi Faraz Hope you are good!

I made changes as your suggestion but doesn’t work :sleepy:

I spend many time to solve this issue without success :confused:


Sorry colleague I don’t understand where I should use clock ?

By the way thank you so much for your help!

Are you retrieving data from airtable ? Are api key, base id , table name correct ? Are columns names correct ? Do you have any empty row or cell in airtable ?

Use Do it on global variables and post a screenshot

Hi Dora.

Yes everithing is correct on Airtable Side.

On the Listview is posible to see Airtable data but when screen open error message apear after cancel listview load data

So the error pops when you try to pick and item from listview ?

No, just when screen load (open) … After load don’t show anymore

Try adding a clock component as suggested above

1 Like

Try to change this blocks position.

Hi Colleagues @dora_paz @WeMakeBest

I used Clock and your suggestion now it works :))))

So happy

1 Like

this is what i suggested… Now a days people are getting select list from item list error if they use multiple column from airtable. That can be avoided by placing such clock component. If they give time to app load data mean everything will work fine.

@Julio_Del_Valle , you can mark @dora suggested blocks as solution for your query and we could close this thread.

Done :slight_smile:

Thank you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.