MySQL Connection Issue

Hi Everyone,

Ive been away for 3 months and this is deffinatly a new problem.

I get a 1101 error when using the app but i get the data returned when i run the exact same query through a browser.

Ive tried changing the web connector as per another threads suggestion. Doesnt work for me.

Any suggestions appreciated.

my guess is, your web host does not like mobile connections
generally it would be great to provide a screenshot of your relevant blocks…

1 Like

thanks, let me try running the query from my mobile

Nope, It returns the values same as desktop

Hi Taifun

I added Network 1 and webviewer 1 and I still get an error 1101

What has changned in kodular in the last 3 months. It was working 100%


which means, these blocks run fine, but the blocks you are talking about, not?

try a simple example project and provide a screenshot of your relevant blocks… those which are not working…


Ok, will do.Thanks

still get a 1101 error

Is there a documentation of that API?
As it returns JSON, you might want to add a request header like


Also you can try the webviewer together with that url, what happens there?


Hi Taifun

As you probably know Ive been developing this app for almost 2 years now. I took a break (was moving
) came back and found that connection that were working perfectly, no longer worked.

I can only assume kodular might have changed something during that time.

your comments? thanks

You forgot to answer my previous questions

Hi Taifun

Probibly cause I dont know what you mean.

The blocks posted are the way I have done all mysql queries throughout the app which has worked perfectly till now > i DONT KNOW ANY OTHER WAY TO EXECUTE A QUERY

please excuse the caps - no shout intended)


If something does not work anymore, do some tests to find out what is going on…

I.e. use the Webviewer.GoToUrl method together with your url

  1. try the example project in App Inventor to find out, if there it still works…


Great! That returns the data in the php page onto the app screen, Now how do I access the data on the screen?


I still find it INSANE that


no longer works???

It looks like there is an issue with your server certificate. .


I see that , Thanks

Might that be the cause? and if so, how can I rectify that


It does not look like to followed that link I posted together with my last answer…
You might want to do a Google search for ERR_CERT_DATE_INVALID yourself…
Or ask your admin…


but even if the date is wrong how will that impact on the ability of the app to not return data from the query?

what if i canel the https?

I get this???

Im absolutly devistated. After 2 years of development to

  1. get a limitation on extensions

  2. for my queries not to work??

Im upset. reallly upset

Your server does have a ssl problem…
Here is a similar thread HTTP OK, HTTPS with 1101 error - MIT App Inventor Help - MIT App Inventor Community
Use another server or fix these ssl issues
This is not a Kodular issue…

I will try another server first.

Much appreciated


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.