Navigation google maps

Fixing: you added the timer to the blocks that @gustavoqueirozmit had already typed looking at the video on youtube, right? :+1:

i use google maps my key = removed by mod
can you test this key please?


i use google maps

google maps api ?

1 Like

yes api google maps

Navigation needs api key from OpenRouteService

https://openrouteservice.org/

3 Likes

and if my app exceeds the openrouteservice api requests, is there any alternative?

This is irrelevant to the problem here. Did you optain a key from OpenRouteService ? Is your problem solved ?

1 Like

that’s why I was using google maps API, is there a way to plot routes with google maps API?

You can see an example here

1 Like

Use google maps api here The Directions API quickstart  |  Google Developers

I suggest you to use web component to get response from request direction with google maps api

Ex:

https://maps.googleapis.com/maps/api/directions/json?origin=Disneyland&destination=Universal+Studios+Hollywood&key=YOUR_API_KEY

The same thing happened to me with https://openrouteservice.org/ with map and navigation, I did not insist because placing coordinates less than 350 m worked for me I see that openrouteservice placed that restriction of course if I am wrong it would be good to have the solution

1 Like

Error 4003: Routing Service failed wuth status 4004 Not Found, when request to navigation.

how its solve. please help me

:point_up::point_up::point_up:


this is code. 4003 error how its solve please explain

don’t understand how solve ?

Connect to companion,
then rightclick and “DoIt” on the related components,
this is the usual way how to go on a bug hunt.

1 Like

please solve problem

You will need to solve the problem yourself. Please follow the suggestion

Of course he does. As you can see his last post was addressed to himself :wink: