No doy dónde falla / I can't get where is the fail

Hola a todos!
Empecé con kodular hace poco, hace muchos años que programaba (Cobol y Pascal :sweat_smile:), y Kodular para mi ha sido reencontrarme jejeje. Pero ahora necesito ayuda, por favor.

Tengo el fallo siguiente. Entiendo qué fallo es, pero no doy donde se produce. He ido inhabilitando bloques por bloques del programa para saber donde salta, pero no lo encuentro. Sale al principio, antes de hacer cualquier acción. Y todo el programa funciona bien. Pero este error siempre sale.

Mi pregunta es si hay alguna forma de rastrear un error. Para saber que lo ocasiona.

Muchas gracias!

Hello everyone!
I started with kodular recently, many years ago I programmed (Cobol and Pascal :sweat_smile:), and Kodular for me has been to meet again hehehe. But now I need help, please.

I have the following ruling. I understand what failure it is, but I don’t give where it occurs. I have been disabling blocks by blocks of the program to know where it jumps, but I can not find it. It comes out at the beginning, before doing any action. And all works fine. But this error always shows.

My question is if there is any way to track an error. To know what causes it.

Thanks a lot!

Hi !
Pascal :+1: Clipper :+1:

Show us your blocks

And use “do It”


Behind that error message I see that you set text to select item list … block. Dismiss the error and post a screenshot of your blocks

Thank’s! I tried!

Here my blocks

thank’s a lot!

May you may have used same procedure in two places especially screen init and also after doing some operation… and your error due to that but after screen initialise and the logic you got data so you are seeing the error. May be not. Pls go through with your screen init block deeply

After got all rows, if you use one clock to timer and after the clock timer if you use the for each number block then the error may be skipped. Since you are using jsonarray extension, it will take some time .

I meant this event block to go after the click timer

Do you get such error if you disable this block? Pls check… if you do then problem with someother

Thank’s for your reply!! very quick reply!!! :smiley: Yes, I get the error when I disable this blocks.

Set all initialize global variables to make an empty list


1 Like

fact!! :+1:

I’m discarding blocks, but I still have this! I don’t get it. :sob:

Disable all blocks, enable first only when screen initialize block, test. Then enable got all rows block, test… etc

That’s what I did!!

and when I enable this block i get the fail!!

But, this block run when I touch an item from the spinner. Why i get the fail without touch it?

I had been looking for the mistake since yesterday and I could not get it. 1 hour here and got thanks to your help!!

Instead of clear list, just try with
Set list_view_articulos elements to create empty list.

We have tested clear list block but it gives error, may be it is a bug. But if you do create empty list, then list view will be cleared

Also make sure when to clear the list elements. After selecting Today or for all selection…

1 Like

Also I think you are running same procedure in two places, when airtable got row as well as here. That also please see to that.

If nothing works, do not hesitate to share your aia… you will be get help soon rather than creating more and more posts

1 Like

As suggested post here or pm me your aia to give it a look

1 Like

Thank’s a lot to everyone for your quick help!!! has been incredible… I got fix it and learn a bit more about Kodular thank’s to everyone.

The error was in this block. I thought that this block only was run when select the list picker. But when the screen start, it executed it. So, selection index has no data and give result 0. From here the error.

Glad your problem solved… But we found no list selection related blocks in screen initialize… so cross examine your aia

Exactly. There aren’t. But upon entering the screen, that block runs for some reason. It may be that when filling in the options, it will run. I don’t know.