O erro "No peer certificate" continua no componente OCR

Describe your issue

The OCR component of Makeroid keeps returning the “No peer certificate” error even after the last updates, I do everything as it was taught to me and the error keeps appearing to me.

Steps to reproduce the issue

I add the OCR component, add my API code, define the required blocks, export to apk, test the function, and get the error.

Expected Behaviour

The text is obtained in the image and typed in Textbox

Actual Behaviour

Without text, and I get the error “No peer certificate”

Show your Blocks


Android version

Android 5.0.2, Galaxy Gran Prime Duos

I Had googled the error u got and just came to know that only this error belongs to websites and hostings. :thinking:

Make sure you have added correct API in OCR properties

Also please try to write English Because we all even me can’t understand your Language

I use the free ocr.space api.

And sorry, but I do not speak English, this is being translated by Google translator, it may not come out perfect.

I tried now with Kodular 1.2 and the same error happens, I already changed the API and nothing has changed.

Don’t know if the ocr component has the same image limit as ocr extension which is 1MB.


The image in which I took the test has 365 Kb.