Problems deleting item from list

Serious problem here. Note that apparently the blocks below are correct. But if I run then the app closes and shows no error in the kodular simulator. But if I disable the block of the first IF or the second IF, the error does not happen. My question is, why running both together does the apilcative close? I even put it separately inside a procedure called through a clock with 5s, but it was no use.

I can see a lots of errors on your blocks! :roll_eyes:

1 Like

The fact that Get CHOICE is with X is no mistake! It is because the project was made in English and I am using the language in Portuguese, nothing but that.

I found out the cause of the problem, and it has to do with a topic I posted days ago with another problem.
I disabled FIREBASESTORAGE1 as it seems to cause conflicts when using in conjunction with FireBase_DB !. Would anyone know why this happened?

I am having problem to understand as blocks are in Portuguese language! Wait for someone else to reply.
Or you can post an English version, if possible.

Actually the problem of being in English or Portuguese is not the x of the question, the problem itself, and why are the Firebase and Storagefarebase commands in conflict if executed together? As I reported above, if I do it separately, it will not give any problem. Note that I disabled FirebaseStorage and the problem is over.
But follow the English version

So, what now? Does problems resolved?

Yes, problem solved, but the question remains, why does this conflict happen? Would it be a bug in Kodular?

Using Firebase Storage extension
with delete filename don’t work even using it alone. Is it problem of Kodular or Extension? Can I have a answer?

can you show how you are trying to delete that, like you are using full name of file and make sure you have checked capital words in name and file extension

This is a file and this is a method

App crash. Only using Filebase Storage. If I use Firebase clearTag: and after FirebaseStorage Deletefilename: crash the same.
In firebaseStorage ,Google database, is deleted. But after app crash.

but for me its working fine, and deleting file from my storage.

blocks - 2019-12-28T223456.445

1 Like

:sob: :sob: :sob: :sob:

good for you. Now i check with new app

have you set write permission in Rules?

I think this are good rules.

1 Like

yes rules are good. there must be something. try that in any new app.

just make with another app.
The api key web is the same of Firebase.
Bucket is right.

I don’t know why don’t work.
Firebase work all.
MimeType application/zip
Firebase storage work for load data but don’t work when i delete. Right, work, file is deleted, but app crash.