Professional clock app

set your display on 480 dp and check please gave feedback on that

Send blocks.

Below are some suggestions/bugs

  1. Let the user know that he/she can enter a custom message by clicking the default ‘Alarm’ text.

  2. If I click Set Notice button without entering any message then after that I cannot add the new message. If I want to do the same then the only way is exit and launch the app again. Below is a small clip depicting the same :point_down:

  3. After entering the custom message and clicking Set Notice button, the keyboard doesn’t hides. Screen-recording :point_down:

  4. The multiline Notice message doesn’t fits/appears well. Screenshot :point_down:

1 Like

I no longer have my rooted device, I have no way to change

My isn’t rooted but I’m able to change

How do you specify your values for positioning clock dials…

Hello everyone,
I am going to launch the update in a clock app. Here is the feature of the updated app
Bugs are fixed:

  1. bugs with circular moving clock ( it take few time to load and its not completely solve)
  2. bugs regarding stop watch
  3. bugs in alarm section also fixed ( User can know where they can change the notice , and problem with lengthy sentence also solved, no need to open app again an again if you not write anything in notice)

Here is app:
Clock 2.apk (8.0 MB)

Through Time


Wait it take time and i also mentioned in post it takes time and its not work properly

How can it take time to get a correct position?

I trying to set this problem

Sorry to say, but still there are bugs present in app including the one mentioned above by @Mateja

  1. It sometimes shows wrong time

  2. If I hit space in Notice message text-box, the the same problem :point_down: that was mentioned in my previous reply occurs

Short video clip :point_down: explaining what is happening now

Also the keyboard still doesn’t hide even after the Notice message dialogue is dismissed

  1. Generally for minutes section ‘00’ appears after ‘59’. But in your case after ‘59’ there is ‘60’ and after that there is ‘00’. Screen-recording :point_down:

  2. This is actually a suggestion. If you want to limit the user from entering more than 40 characters in Notice message, then limit in such a way that after 40 characters user will not be able to enter the text.
    Currently there is alert for 40 characters coming when the count exceeds but even though user can enter more than that and then after when he/she presses the Set Notice button then you are displaying the error toast and making the message blank.
    Also after the error when I reopened the Notice message dialogue the error alert symbol was still there without any reason. Screen-recording :point_down:

The stopwatch is…too fast…


  1. in my device it show perfect time here is a screenshot

    I will looking forward to your problem and in next update i will improve it if you have any more bugs then please suggest me i will improve that.

In my device it works properly but I don’t why not in yours

Dear , in second bugs keyboard is hide in my devices here is screen recording

60 is the same thing as 00?
Remove the 60 option from minutes.

Hello ,
I updated the app in this app i fixed the bugs that as follows:

  1. Instead of 60 min i change 00.
  2. If you entered the space then it will show the default message ( don’t press space more than onetime without entering the text)
    Clock 3.apk (8.0 MB)