Runtime Error for Makeroid

I’m developing an application using a makeroid. But I get an error in the program. I have added a push notification extension in my app and integrated it with Onesignal. However, my application started to receive errors after this process.

When I press any button in the application, the application shuts down or the error issues a Runtime Error. I tried to show the error in the picture I shared.

My application is now locked and unfortunately we cannot advance the project.

What can I do about it?

Share your aia, show your blocks and share a apk.


The code blocks are very crowded. And there’s no mistake. So I’m not publishing a code block picture. Instead, I shared aia.

Please share too the apk.
A apk is easier for me to know what’s wrong.

1 Like

I’m getting an error on Screen4.

Maybe you should tell us the steps to get the error.

When screen 4 is opened, I get the error on the screen when I press any button.

8 Eki 2018 Pzt 16:50 tarihinde Mika [email protected] şunu yazdı:

You’re missing an image on a block or component which run under the initialize block or at runtime.

When initialize screen
Load image 2 , Second screen fix it :slight_smile:

I’m sorry I don’t fully understand what you mean. Can you explain a little more? What can I do?

Show your blocks for screen initialize

the code block is too long and unfortunately does not show everything in one image. Instead, I shared the aia file. The problem can be found there more comfortable.
Can you help me?

If you want people to help you you should provide the blocks. Very few people will download an aia, import it into makeroid, start it up and start testing for you.

1 Like

check all your Notifier icon socket’s, it has space in it.

to clarify this



Thanks for your warning. I didn’t know how it worked because I was so new here. I will load the blocks as soon as possible


This post was flagged by the community and is temporarily hidden.