[SOLVED]Error 3407 Line string/Navigation/Points I can't find the right format for points line string

Hello, I made a navigation system with open route all works well except that we are limited in requests.

So I got a free api that sends me the coordinates of the points, I receive the format this way:

“type”: “LineString”,
“crs”: {
“type”: “name”,
“properties”: {
“name”: “urn:ogc:def:crs:OGC:1.3:CRS84”
[2.613764, 48.941337]
,[2.614014, 48.941332]
,[2.614150, 48.941342]
,[2.614895, 48.941452]
,[2.614770, 48.941739]
], “properties”: {
“distance”: “2.324212”,
“description”: “To enable simple instructions add: ‘instructions=1’ as parameter to the URL”,
“traveltime”: “326”

I know that with open route I get the list of points from like this (48.941739 2.614770) (48.941749 2.614770)

They are in an accessible list with a select item list I can get each of them independently.

So it was my turn to create a list that was identical to the open route list. In any case in a text view it’s identical but I always get error 3407.

Here is the top text is the processed text coming from the API
I display a list :

the text below the button is the text that Navigation in kodular provides the Points element

I know that the longitude and latitude are not in the right order in the API but I tried the opposite and it doesn’t work either

Here is the processing block of the API

Do you have an idea why Line string doesn’t accept points? What is the format used?

I also tried [8.2554, 2.54874] I tried 8.2554, 2.54874, also (8.2554, 2.54874) Line string does not accept.

Your help would be welcome, thank you

I found the solution!

So I used this block
blocks (8)

But the concern is that the api returns longitude, latitude.

And the block needs latitude, longitude.

So I had to invert it is 2 data

Here is the treatment to do :

This should send this back to you

[48.941337, 2.613764]
, [48.941332, 2.614014]
, [48.941342, 2.614150]
, [48.941452, 2.614895]
, [48.941739, 2.614770]

1 Like