Text file is saved without text

Saving a text file but saved as an empty text file. Tried different text and different file name but same result.
Also, (Append to file) not working. just saves an empty file.
Android 10.
Any quick help is appriciated.

File name = file path + /file name

thanks, but I am saving it in ASD, and It is saved successfully every time. But the problem is with text.

Show read text blocks

There is no use of that in this because I manually checked the text file from file manager, which shows empty file (size - 0b). Also I deleted this several times and tried again [with DO IT command], but same issue, File is created but with empty text.

Make sure that event blocks is generated text to save the file as .txt. file size is zero mean,may be, there is no text is generated it seems… else use one if else condition. There by if no text is created you can use specific text to cross verify what is generated in the event block

I believe you asked the same question in …

At that time problem was solved as I used SAF extension there, but That asks for permission after every reboot, so I used files component this time and I did everything I could do but I am still unable to solve this problem, Can you please take a look at my aia plz? @dora_paz

Try this (on your test device):
FileSave.aia (2.4 KB)




Thanks Anke, @bodymindpower glade to see u, I know that works [After creating another project ] But The problem is with this project, Please see aia file I dm you and check if something is missing or wrong. :slight_smile:

@dora_paz I also dm you the aia please take a look,.

The FileTools ext. needs an absolute or relative path. Or use the File component.

That’s why only these two blocks are executed. This means that an empty text is saved and read.


Oh ys thnks, But unfortunately, same result even after correcting this.

Thank you very much Anke for your help, At the last, I was able to solve this issue, The real problem was this :

JsonToDictonary Extension Malfunctions if the Text in the file is not in a valid json format or If it is an empty file (My case). And I soved that at the end… Like this:
Again, A Big Thanks Anke…

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.