Uploading images to web host

i am trying to upload image to my web hosting server using method from App Inventor Tutorials and Examples: PostFile | Pura Vida Apps
butr its not working .

i uploaded the php file in my file manager and on searching its url in brwoser it is showing access denied
and when i try to upload an image it shown image cannot be uploaded

is there any solution of this problem…or if anyone of you gyz doing it perfectly then please share your methodology

1 Like

Can you share your blocks also… ?


I have same doubt

1 Like

But this problem is related to settings on your server.
Error 403 ?

1 Like

why not…

no simply saying that unable to upload i think there is a problem in my files placements or url…May you provide an example of how to and where i have to place the php file and how to access … or is there any guides to upload images using ftp??
m also not succeeding by using FTP component . in FTP component my error is
connection is not open

use the ftp component

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select “Download Blocks as Image”. You might want to use an image editor to crop etc. if required. Then post it here in the community.


1 Like

these are my blocks . in thse blocks i used ‘my domain’ wheever there was my domain and all other things are exactly the same


is there aguide regarding FTp component

What ? :thinking:

it seems to be, you forgot to connect to your server?

I tried with Call connect block but not worked

1 Like

sorry its a spelling mistake .i mean is there any guide regarding FTP component.?

1 Like

Have to try this with rabhost ?

1 Like

@Ottoman yeah i tried but not working. Have you done it ?

No, FTP Component isn’t work with Rabhost

then i think there is an extention too. btw have you uploaded images to Rabhost .

I’m not shure, but i don’t see the block call FTP. Conect, to start the connection with you server.
This block

I’m sorry i don’t see Taifun post. I apologize

Yeah because above post of me is older after Taifun’s suggestion i tried with call ftp.connect block to but it didn’t work for me

1 Like