Webviewer-zoom setting does not work

Hallo,
Kodular Eagle 1.4B.1 / creator: I can set the zoom in the webview component (e.g. 200). however, the settings have no influence on the display.
the content in the webviwer is always shown with 100%.
This problem only occurs in the new version.
I ask for help.
Bernd

I just tried it with 200 zoom and it works fine in my device.

With 100


With 200

2 Likes

as @George_Loungos confirmed that its working, then there must be something turned off from web properties, like zoom enabled or zoom display.

Hello, thank you. zoom works with fingers.
but the display should be enlarged when you call up the screen.
as an example the screenshot of the old modular version.
in comparison the screenshot after the current version.
I didn’t change anything in the webviewer settings.
where is the problem?
many thanks for the help!

My example above is not zoom with fingers gestures. It’s already zoomed from the properties.
What do you have checked in the Advanced properties?

why zoom display is turned off?

Hello,
an html file should be loaded in the webviewer (representation plan of the school).
but this should be shown zoomed. I have not changed anything in the settings in the advanced properties. if I activate “zoom display” nothing happens.
I tried many variants on a test screen - with pictures, with html pages, etc. Zooming out of the proberties never worked.
???

can your share your html here or in pm so we can check that.

hello, i did a test screen. here the aia file and one of our html files. these are generated by a timetable program.
so far everything has always worked.
Thank you very much:test_000.aia (1.1 KB) https://peter-pan-grundschule.de/vertretung/app-h-sch/subst_001.htm

if you are using that same table then you can set your screen to Landscape, so you can check your Table easily.

good day,
the table is not the problem.
I cannot change the table either.
the problem is with the webviewer component.
no matter whether the screen is in landscape or portrait format.
The display in webviewer is always 100%, regardless of whether an html or an image file is loaded in webviewer. No enlarged display is possible via the common properties (e.g. 300).
In the “test_000.aia” there is a webviewer with zoom percent 100 and a webviewer with 300. the ads in the webviewer should actually be different. no matter whether an image or html file loaded format does not matter. the display is the same.
what am I doing wrong. where is my mistake?
Have a nice day.

i dont know why its not responding with your link, maybe your link is html thats why, with else url its working.

many thanks for the help.

for that you can set screen to Landscape and that will works good for you

unfortunately I imagined it differently. Unfortunately it does not work. thanks again.

Yes, but you can try something like this:

1 Like

Try this: test_webviewZoom.aia (2.1 KB)

Hello, thank you
but the solution has not yet been found.
when i create my project in the old version of kodular, the table was shown like this (image_1).
but the display in the current beta version is (image_2).
I didn’t change anything on the project.
of course I would have the representation as in the old version. the width of the table should also be fully visible in the enlarged view. but i can’t find a solution.

In AI2 I get this:

It’s also not possible to get this with Juan’s Webview extension in Kodular:

hello, that looks very good. Thanks alot. I’ll try it out later.