What is the reason for this crash?

at android.os.Parcel.createExceptionOrNull (Parcel.java:2385)
at android.os.Parcel.createException (Parcel.java:2369)
at android.os.Parcel.readException (Parcel.java:2352)
at android.os.Parcel.readException (Parcel.java:2294)
at com.android.internal.telephony.ITelephony$Stub$Proxy.getNetworkTypeForSubscriber (ITelephony.java:8762)
at android.telephony.TelephonyManager.getNetworkType (TelephonyManager.java:3706)
at android.telephony.TelephonyManager.getNetworkType (TelephonyManager.java:3670)
at com.unity3d.services.core.connectivity.ConnectivityMonitor.connectionStatusChanged (ConnectivityMonitor.java:162)
at com.unity3d.services.core.connectivity.ConnectivityNetworkCallback.onCapabilitiesChanged (ConnectivityNetworkCallback.java:48)
at android.net.ConnectivityManager$NetworkCallback.onAvailable (ConnectivityManager.java:3793)
at android.net.ConnectivityManager$CallbackHandler.handleMessage (ConnectivityManager.java:4073)
at android.os.Handler.dispatchMessage (Handler.java:106)
at android.os.Looper.loop (Looper.java:246)
at android.os.HandlerThread.run (HandlerThread.java:67)

1 Like

See here


1 Like

My app is online and i don’t use internet permission “Do you think this is the reason for the crash?”

with regards unity ads topic … the same crash appear in my play consle , and read the solution for this bug is convert ads from API 30 to 29 “but this in 2020” , now still work or what the solution for this bugs?
In my app crash occur when ad interstitial loaded !!

Do you use Unity Ads? That’s what caused it for me. So far I have found no solution

I think I found the reason , your app crashed on Android 11 only ?

If you found the problem it would be nice to share it in order to help others with the same problem

In my case my app crashed on Android 11 only when ad interstitial loaded …

This occur when use wifi connection but when use mobile data crash does not happen and my app is working fine

If you know the solution to this problem, please let me know … “needed to implement certain type of permission in my app??”

Yes it only happens on Android 11. And only with Unity for me, StartApp works fine with intersitials. If the fix is a permission that would be easy to solve. Hopefully someone can help.

Use Network component. Use if internet is connected then load ad else carry on the activity

Means request for load unity ad only if internet is connected.

1 Like

There is no load ad option for unity ads, it loads automatically.

[quote=“mohned_almagrahi, post:8, topic:149386”]
n my case my app crashed on Android 11 only when ad interstitial loaded …

This is invaluable information as I haven’t been able to resolve this issue yet and I also don’t use the permission (ACCESS.FINE.)

let’s get to the facts:
1.When connected to the mobile network the ads are from local companies, so it means that the mobile network can better understand this location than the Wifi network.
2. I get failures from API30 devices only, but not all of them, many do not have failures.

I will try access.fine permission only for API30 and see the results.

Any results? I had to disable ads for android 11+ cause nothing worked…

Tried using again and lots of errors, had to disable again

I am having the same issue where the app is crashing for Facebook Banner/Interstitial with Android 12 now. Was anyone able find a solution for this?

Also, I notices that the Notifier Component is not working on Android 12.

Appreciate your help