Android 10 App Installer with KIO4Install not working

Instead of provide 2 extensions… Why dont you create just one extension and make there android version checks?
It would be much easier for people to use then your extension.

Ty :smiley: and after completing the download do you use the activity starter to start the installation?

Tested on Android 10, not working (see the screenshot)

yes, as described here

1 Like

i am very new here .
how do i setup for scoped storage for android 10 and eventually 11
can a link be added this has to have been asked

I have updated the extension, I have not tested it on all versions, but I think it should work on Android, 5, 6, 7, 8 and 9. On Android 10 it doesn’t work.

It is com.KIO4_Install_v3.aix

Edit: goto message 34

1 Like

not working on android 9

1 Like

blocks - 2020-03-31T123820.504

@vardandevelopersassociati I moved your anwer into the correct thread…
did you use the latest version 3 of the extension, see here?


@gleminem1 @vardandevelopersassociati

Are you using your own package name as the error message in the image looks familiar.

If so try with default package name

i have changed my custom package name ,if i change again it to default i will find other issue

I Tested This Latest Version V3
It’s working on
Realme 5 Pro Android 10
Huawei Nova 3i Android 9.1

Infinix Smart 4 Android 9.0
Huawei P8Lite Android 5.0.1


Yes, I confirm.

1 Like

@juananton1991 This issue is because apps on newer Android versions must use a File Provider in AndroidManifest.xml.

By this error, I’m assuming you’re using intent.setDataAndType(FileProvider.getUriForFile(context, Uri.fromFile(file).getAuthority(), file), "application/") which I just tried and got the same exact error.

I recommend to switch over to the PackageInstaller since it will work for Android 5+. Although I have tried this already, I didn’t get errors, but the APK didn’t install.

Maybe some would like to test this APK to install an APK (testAPK.apk , 3MB / AI2) (which is in the assets or can be downloaded from Google Drive and is copied into the ASD).
(ASD = app-specific directory)
installAPK.apk (7.9 MB)

So check this especially on Android 9 and 10.



Try adding GRANT_READ_URI_PERMISSION flag to intent.

1 Like

Yess, It worked :tada::heart_eyes::heart_eyes: Finally
Install Sucessful Both in assets and downloaded.
Problem in deleting file. Says file dosen’t exist.

Checked in Android 10

1 Like

Because it tries to delete all files (also from the folder /Download). But if you haven’t downloaded from GDrive, this file doesn’t exist. So no problem. Its only to simplify testing.

1 Like

It worked in android 10…:star_struck:

1 Like

Sorry I do not know but can I ask that this extension can install app in background ?