Backpack limitations?

Hi, i just recently switched from AI2 to Makeroid and have some issues with the backpack. My first post in this forum. Does anyone know if there are limitations with the backpack (ie number of blocks that can be copied at one time?)

This is how my issue was created:

  1. Imported .aia file originally created with AI2 into Makeroid. 7 screens with multiple blocks. Warnings displayed in Makeroid environment about incompatible components.
  2. Created a new app in Makeroid with the same 7 screens.
  3. Re-opened the imported app, copied all blocks from the first screen to backpack.
  4. Opened the new app and tried to paste the blocks into the corresponding screen. Only about 30% of the blocks from the backpack were pasted into the blocks window and unable to bring in the rest. The backpack then became unresponsive - ie would not even show contents.

Has anyone else seen this behaviour?

I tried changing browsers but the issue is the same.

I would appreciate any advice.


Make sure that all your components have same name as on the blocks.
PS Also make sure that you have all the components of which blocks you want to paste.

1 Like

I don‘t know if this „bug“ fixed but I upload a project on version 1.0.1 and I must change all the „get ResponseContent“ and other blocks like this to the name with space.


 Get ResponseContent

Change to

  Get Response Content

Look at these kind of warnings and errors and try it a second time

Or your right and there is a limitation for the backpack…

Have you tried to paste only the half of your blocks to the backpack? Try this and look if there also only 30% of your blocks pasted to the screen

Thanks Shreyash

Your comment helped me to find what was causing my problem.

I managed to trace the issue to the BluetoothLE component that I was referencing. Event though I used the same BluetoothLE extension in AI2 as I did in Makeroid (i.e. I imported the same .aix file) and I ensure that the component in both applications had an identical name, within the Makeroid environment the component publishes slightly different properties and methods.

Interestingly, when I imported the app from AI2 to Makeroid, the code blocks in the imported application used the same properties and methods as in the BluetoothLE component in AI2. But, when I created a new app within Makeroid, placed a new BluetoothLE component and then tried pasting code blocks from the imported app, this is when I started having problems pasting from the backpack. I think that, because the BluetoothLE methods in the imported app and the newly created app were slightly different, the backpack “stopped” pasting any block that contained an unrecognised property or method.

My solution was to copy and paste only blocks that contain references to objects that are identical in both apps and to re-create blocks that reference components (e.g. BluetoothLE) that have differences in their methods and properties.

Perhaps a future Makeroid update should consider displaying an “unrecognised property or method” error message.


1 Like

If you find it helpful just mark it as a solution, so anyone having same problem can refer to it.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.