Block is not executed - Only works manually with "Do it"

Hello everyone,
at first everything worked. Then suddenly not anymore. So it’s about the first block in the procedure.

I’ve already tried without a procedure, with swapping the blocks, without the progress dialog, but everything didn’t work. It only works when I do it manually, so with “Do it”. I’ve already downloaded and installed the app, but it doesn’t work either. I also deleted cache (browser and app) and tried another browser, but without success.
blocks (2)

Does anyone have an idea? Thanks in advance.

Do you call the procedure?

Yes. Everything in the procedure works, only the first block does not…

From the documentation:


a .KeysGenerated event is raised to return the values, this will happen outside of your procedure. Handle your generated keys in this event block


I know. This works when I run it manually.

But I found a way. I just use a timer. It works there. Apparently screen initialization is too early to execute the block. I had not thought of that. But thanks anyway!

As far as I know, the blocks are simply processed one after the other.

There was no mention of Screen.initialize, but it shouldn’t really be a reason to avoid the process there. If you put the call for process “newk” at the end of Screen1.initialize, there should be no problem at all.

It’s at the end of Screen.initialize, but that won’t work. It works with a timer. Idk why.

Yes that’s is a known issue.
It does not work on Screen Initialize.
Even if you call it after 0.001 sec after Screen Initialize then it will work. :sweat_smile:

Most of the times it is true.
But sometimes you need to perform long running operation which can’t be run on main thread so we have to run that in background thread and post the result to main thread(using event) after operation is completed.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.