Cannot import project

Unfortunately yesterday a large project that I have been working on for several years was destroyed,
Luckily I have a backup, but it can not be imported into Kodular, I tried to import it several times but each time nothing happens.
I tried importing from several different browsers but it did not help.
I guess it’s happening because it’s a pretty big project, the aia file size is: 9.7 MB

Here are some data:

  • The import was successful on the Kodular beta site

What kind of app are you making exactly?

send the aia maybe we can try importing it

whats the Kodular beta site

I will not send the project here, even if I sent and you were able to upload it to your account it would not help me

App seems really nice.
I don’t know how you manage to such cool stuffs in your app. Probably you are using many arrangements, components, extensions, assets so your aia is very big in size.
It is probably because of it’s big size.
So, what error message you get while uploading? or what exactly happens when you try to upload aia?

1 Like

Thank you. Basically what happened is that after uploading you can see that the site is loading, but nothing happens. In the screenshots I attached you can see that the server failed to meet its task and the project will not be imported

Basically all this problem happened because I imported a block to the block editor whose extension does not already exist in the project, and the next time I opened the project all the blocks on this page were deleted

Do you have any files in assets with spaces or () brackets in their name?

I’ve also faced such problem and I Boban helped me out.
He said: "The only way I found to fix this is to export the aia and go thru screen bky, scm file manually and look for abnormalities"

The aia is fine, you can see that I was unable to import the project into the Kodular beta site

1 Like

You could try removing all assets from the AIA and then re-upload them once the project has opened


I tried to do it, but after uploading I got a message that it was not a proper project. I’ll try again. Is there a limit to the size of the aia that can be imported?

*(I changed the extension to aia)

Why do you have to change the extension to aia?
What was the extension before?

Open the aia with 7-Zip or WinRAR:


open (double click) assets and src

and make screenshots.

1 Like

He might have changed apk to aia and that would not Open in kodular as apk is the combined file and aia is the source code file

Aia contains the blockly code that’s not there in apk that’s why it’s not opening I guess

No, I changed the extension of the project from aia to zip, and after editing I changed again to aia

Why? Because the aia is already a zip file.

The zip opening process on Mac may have caused some problems, I will try with the software you specified

Otherwise I will not be able to open the file as a zip file