Companion Connection Error state = disconnected

Describe your issue

when testing app using companion i get an error - Companion Connection Error state = disconnected

tried 3-4 times but getting same issue…

Steps to reproduce the issue

Go to Test - Connect to Companion - scan qrcode using companion app - error

Show your Blocks

Android version

Android 9 (Honor 9 Lite)

2 Likes

Happened to me once, the reason was the awful internet connection.

1 Like

This reply of mine may not be related to the query in anyways. But I just wanted to check that, I think in your blocks above the blocks under the event, when Screen1.Back Pressed can be replaced by :point_down:

or if you are checking something else then please let me know, so that I will learn something new.

and for your query, I have received such error in two cases

  1. As @ontstudios said whenever the internet connection is slow OR
  2. When there is no activity for several minutes after the companion is connected

i dont think internet is the issue here… 60 MBPS…

@Vaibhav thanks for the suggestions, i will look into it later…

error happens on the process of companion connection…

Hmmm… :thinking: just a wild guess, try to hard reload (Ctrl + Shift + R) your browser and try connecting again

Same issue.

Android 10 (K20 Pro)

1 Like

I am facing this issue since yesterday and this forced me to use AI2 for testing.
I am using emulator running on Android 5.0

1 Like

ok… let me try…

i also facing the same problem and i have a good wifi speed internet

1 Like

The same thing happens to me when I use Firefox, but with Chrome it doesn’t happen to me

1 Like

same with me it gets stuck on 43%

1 Like

I reinstalled the MIT AI2 Companion on 2.57b. I think it works reliable…

Same here, but i don’t have a good internet connection​:zipper_mouth_face:

  1. Creator shows that Companion disconnected but some times companion is still connected…
  2. Companion gets disconnected
    (Creator shows error, Companion no longer refreshing)
    But on resetting connection on Creator after Companion disconnected, the Companion app gets closed (exits/stops)
1 Like

I am facing this issue since yesterday and this forced me to use AI2 for testing.
I am using emulator running on Android 5.0
it is very important to be fixed< the issue is not related to the internet < as i have been never
encountered this problem before , despite the weak internet or running the emulator on android 5.0

Why not test using your smartphone?

On your pc open kodular creator,
install companion on your smartphone,

Connect companion and done!

Companion best works in real smartphone even side menu is also works on companion. :smile:

In my condition, I use two smartphones,

On one device i use kodular creator,
And on second companion.

It works perfectly…:wink::blush:

Yes :weary:.I do .it’s don’t work.
I am off work.:mask:

1 Like

Don’t work to me also

facing the same issue, isnt the speed of internet, i tried with remote and local ip (same subnet), cant work in that way, tried with kodular usb, but the millenar error of internal bug still there. i dont know what to do more.

My project is not connected companion now
And my internet speed is very fast