Error after importing project from App Inventor

Hello Makeroid Community,
I just imported my project from App Inventor to Makeroid getting help from this tutorial (to change package name so I can publish it again as the same app.):

When I try to create an .apk, I get the error below as a yellow warning bubble at the top.

Error generating Yail for screen 4554960926670848_Screen1: : Cannot read property ‘type’ of null. Please fix and try packaging again.

What does this mean and what can I do to make this error disappear?

Can you show the blocks and the components?

Here are the blocks (all of them):

Here is the app interface:

Here are the invisible components:


Here are all of the Properties:

Hope you can resolve the problem :slight_smile:

I think I know the issue:

Can I see all the properties for all textboxes?

There are a total of 2 text boxes.

Here are the properties of the 1st one:


and here are the properties of the 2nd one:

Humm, can I take a look to the .AIA?

Do you want me to export the .aia file from Makeroid (after transfer) or from App Inventor (original: before transfer)?

Makeroid one

ai_Randomer.aia (491.7 KB)

Here you go :slight_smile:

@Diego have you found a solution?

Not yet :sweat:

I have lots of exams, so until the 27th I won’t have much time…

Oh, OK. I will be waiting always.
(Good Luck with the Exams :slight_smile:.)

@TurboProgramming, just a suggestion: Try to delete the components, one by one, and after delete it, try to generate the apk, until discover the error. This error can be related to a property from a component that internally was migrated with null.


great idea, but it will be soo hard to do it :frowning:.
But I could start the project from the beginning, that would be easier :slight_smile: (As it’s a small app.)

Thanks for the suggestion @Kleyber_Derick :slight_smile:

1 Like

You can replicate a project by choosing

File > Save Project As

by that what do you mean? @pavi2410

I had the same problem and it was solved by unchecking the option “NumbersOnly” in the TextBox components in AppInventor before exporting the AIA file, as suggested here (, try that!

1 Like

I will try, if it works I will let you know!

By the way thanks for the tip! :wink:

If this is the error I will take a look at how why this is happening. I think its because we didn’t remove that property the right way.

We have done it wrong :smiley:
I make current some tests on it.

I have changed something in our code and importet a project form AI with a textbox where the numbers only block is enabled.

Then I have importet the project into our builder.
The apk works now. No crash. No error.
I make more tests on it.

1 Like