Export apk doesn’t work, invoking AAPT, stuck at compiling source files

help, i have been getting the same problem, three of my top apps wont compile, i tried to build an empty project and got the same problem

Two common mistakes by user that produces this error


You should also search the community. This has been asked many times before. Please search before asking.


Check in your first screen if have simbols in the options, for example, the Version Name dont compile if is a "(Simbol) in it

What’s the meaning of that??

This used to happen to me before. It is possible that your internet connection is weak.

Export your AIA and open it with a descompactation program, 7-zip works fine, and check in external_comps if have another folder with assets, src or youngandroidproject


If I’m not mistaken, everything is explained if he follows the link…


thanks! the issue was project in a project. i deleted the files using 7zip and it was able to compile… thank you so much!

1 Like

my internet speed is fast enough, the issue was project in a project

I see you have more then one account on the community. Only one is allowed. Which one should i delete?

hey pete, pease delete the one for nexantrends, i tried to open the project with that email cause i thought the compiling issue was with my account

if you delete that account, will this thread still be available for those facing the same problem? if not, delete this one.

I will close the other account so it can not be used anymore. So this topic will be visible.

sure. thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.