[FREE] OneSignalPush: Integrate latest OneSignal SDK (5.0.2) in your app to send Push notifications [DEPRECATED]

Pm me apk.

Hello, I came across a problem / bug.

When a user denied the notification permissions, everytime that user will open the app a message will appear saying “cubic-beezer(0.4, 0.0., 1.0, 1.0)” with 2 options: Cancel or cubic-beezer(0.4, 0.0., 1.0, 1.0), if you press cancel it will disappear, if you press the other button it will take you to the notification settings of the app.

How can I get rid of this? Is this an intended feature?

If you need a picture of my blocks let me know.

Yes, show blocks.

I’m having the same error as @Eric_Laufer, but i couldnt solve it, there is no location sensor in that screen and i’ve already imported depsv2 and pushv3. What could I try? Thanks @vknow360

You are getting error in apk? Or companion?

In Companion (I know it wont work in companion, but it should not throw an error every time the screen refreshes)

If developer mentioned clearly to not use it in companion then why complaining over that.

1 Like

How are we supposed to add it then? Adding it to any project causes errors that stop app from loading after them, how this would be useful? Do I have to just remove it when I’m working on my app and add every time I want to export it? Thanks,


1 Like

Hello, I am using Push V3 and deps v2 for my app with only one screen with a web viewer. But push notifications are not working. I tried with both SDKs Native and Server API but its not working. Please check my blocks and help me.

1 Like

PushOptIn will not work if notification permission is not granted.
So, after asking for permission, start a timer of 10 or more seconds and when time completes check if permission has been granted or not. OptIn for notifications only if true.

Please check. I am new to kodular/niotron i am doing this in niotron and don’t know much about blocks

Hello! I’m new to the community (just recreated my project here for a school project and improved with Kodular’s components and your extension).

Knowing that Firebase auth won’t work on this extension, I implemented a web component authentication instead with Firebase Auth REST API before adding the extension.

My app has 4 screens but I’ll only highlight the screen that is involved: Screen1 (Loading screen) and MainScreen (Primary UI)
I added the extension and the dependency on MainScreen. I exported it as an APK for a test, but it crashed. This happened during screen switching (Screen1 > MainScreen)

Digging down to adb logcat it said: Unable to start activity ComponentInfo{(package name)/io.kodular.rendamanjunjie.(apk name).MainScreen}: java.lang.IllegalStateException: Default FirebaseApp is not initialized in this process: (package name). Make sure to call FirebaseApp.initializeApp(Context) first. Yeah, another runtime exception.
The only Firebase components on my app is the Firebase Database and Remote Config

Tried placing it on Screen1, and it worked fine during loading, but during switch, it crashed.
Tried placing both screens, still crashed :frowning:
Even if I don’t initialize the component using the block “Initialize.appId()”, still crashes.

So I tested your .aia again and added another screen with Firebase database (I also added Firebase component on screen 1 as another test) then exported it as APK and that worked fine. No crashes.

I don’t know what could be the solution since I tried searching a lot and had no luck, and still in confusion, any solutions? Your response will be helpful to me. Thank you!

This might be the reason.

I have no solution right now.
But I’ll make sure to find a workaround after 6th April.

I see, I’ll test it again, will update later.

Upon testing, (this time I configured my app to exclude Firebase Remote Config and your .aia project file to have google-services.json with Firebase Database and Firebase Remote Config, exported as APK)

I successfully recreated the crash [Default FirebaseApp.initializeApp(Context)] to your .aia project file. Now, removing the Remote Config to your .aia file, the crash resolved but for my project, it still hasn’t been resolved, same runtime error though :slightly_frowning_face:, only removing the extension resolves the problem in APK.

Oh well, I recently saw a post that a person also has that kind of runtime error but unfortunately, it didn’t get answered. Topic link: [New info]Firebase authentication , app crashes on impact - #11 by Mikolaj_Krajewski_Wario_SSeems like I have a similar case from this post.

I guess I’ll wait for the fix or any methods that could work on it.

Looking forward to it after April 6, I really wanted to add a push notification capability for my app.

Edit: Yep I fixed it and it was my unused Firebase Storage (I used your cloudinary extension instead because cloudinary was easier) :skull: I may have overlooked my components list, I thought it was another Firebase Database component, sorry about that but hey it works now!

Hello everyone,
My question is how to store a particular value after getting a particular message?

Thanks For the Great Extension @vknow360

I have a Query if You May Answer please…

I set up my application as You said … I am Getting Push Notification From Onesignal Api Dashboard,
But Not From the app …

Can You tell me why ?

Definitely I can’t tell without looking at your blocks.

I am too Sorry…
It was my Mistake, if you look at Tag i was not using proper tag } :back: this one … thanks for the great Extension…
Also what tag means ? What if we set it to Blank ?
One more thing can you please Tell how can we set small image to our application Logo ???